summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-19 07:51:32 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-19 07:51:32 +0000
commit5cce1a71968cd6f9cdbb0223d419e8035f3a9608 (patch)
tree51617f53f7f9b417b3988382f485ca5a487096ad /dev-python/pyzmq
parentVersion Bump (diff)
downloadgentoo-2-5cce1a71968cd6f9cdbb0223d419e8035f3a9608.tar.gz
gentoo-2-5cce1a71968cd6f9cdbb0223d419e8035f3a9608.tar.bz2
gentoo-2-5cce1a71968cd6f9cdbb0223d419e8035f3a9608.zip
Version Bump; drop old; fix versions in dependency, obsoletes bug #493298, bug #531398
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/ChangeLog10
-rw-r--r--dev-python/pyzmq/pyzmq-14.4.0.ebuild57
-rw-r--r--dev-python/pyzmq/pyzmq-14.4.1.ebuild20
-rw-r--r--dev-python/pyzmq/pyzmq-14.6.0.ebuild11
-rw-r--r--dev-python/pyzmq/pyzmq-14.7.0.ebuild (renamed from dev-python/pyzmq/pyzmq-14.5.0.ebuild)11
-rw-r--r--dev-python/pyzmq/pyzmq-2.2.0.1-r1.ebuild48
6 files changed, 28 insertions, 129 deletions
diff --git a/dev-python/pyzmq/ChangeLog b/dev-python/pyzmq/ChangeLog
index bf12c49a52f9..c0234f1aca0d 100644
--- a/dev-python/pyzmq/ChangeLog
+++ b/dev-python/pyzmq/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pyzmq
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.76 2015/06/07 09:49:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.77 2015/06/19 07:51:32 jlec Exp $
+
+*pyzmq-14.7.0 (19 Jun 2015)
+
+ 19 Jun 2015; Justin Lecher <jlec@gentoo.org> +pyzmq-14.7.0.ebuild,
+ -pyzmq-14.4.0.ebuild, -pyzmq-14.5.0.ebuild, -pyzmq-2.2.0.1-r1.ebuild,
+ pyzmq-14.4.1.ebuild, pyzmq-14.6.0.ebuild:
+ Version Bump; drop old; fix versions in dependency, obsoletes bug #493298, bug
+ #531398
07 Jun 2015; Markus Meier <maekke@gentoo.org> pyzmq-14.4.1.ebuild:
arm stable, bug #540290
diff --git a/dev-python/pyzmq/pyzmq-14.4.0.ebuild b/dev-python/pyzmq/pyzmq-14.4.0.ebuild
deleted file mode 100644
index 2fe18337a477..000000000000
--- a/dev-python/pyzmq/pyzmq-14.4.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.4.0.ebuild,v 1.9 2014/12/30 16:58:13 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-IUSE="doc examples green test"
-
-PY2_USEDEP=$(python_gen_usedep python2_7)
-RDEPEND=">=net-libs/zeromq-2.1.9
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi[${PYTHON_USEDEP}]
- green? ( dev-python/gevent[${PY2_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="test? ( green )"
-
-python_configure_all() {
- tc-export CC
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- if python_is_python3; then
- einfo "Skipping python3 due to lack of support by gevent"
- else
- nosetests -svw "${BUILD_DIR}/lib/"
- fi
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyzmq/pyzmq-14.4.1.ebuild b/dev-python/pyzmq/pyzmq-14.4.1.ebuild
index 2955f2c3a9ec..71cc7e702c77 100644
--- a/dev-python/pyzmq/pyzmq-14.4.1.ebuild
+++ b/dev-python/pyzmq/pyzmq-14.4.1.ebuild
@@ -1,39 +1,37 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.4.1.ebuild,v 1.11 2015/06/07 09:49:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.4.1.ebuild,v 1.12 2015/06/19 07:51:32 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
inherit distutils-r1 toolchain-funcs
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
IUSE="doc examples green test"
+# Ensures installation of gevent for test phase
+REQUIRED_USE="test? ( green )"
+
PY2_USEDEP=$(python_gen_usedep python2_7)
RDEPEND=">=net-libs/zeromq-2.1.9
dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
green? ( dev-python/gevent[${PY2_USEDEP}] )"
DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/numpydoc[${PYTHON_USEDEP}]
)"
-# Ensures installation of gevent for test phase
-REQUIRED_USE="test? ( green )"
-
python_configure_all() {
tc-export CC
}
diff --git a/dev-python/pyzmq/pyzmq-14.6.0.ebuild b/dev-python/pyzmq/pyzmq-14.6.0.ebuild
index dd22c9b2d953..2fc505e63a56 100644
--- a/dev-python/pyzmq/pyzmq-14.6.0.ebuild
+++ b/dev-python/pyzmq/pyzmq-14.6.0.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.6.0.ebuild,v 1.1 2015/05/14 01:38:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.6.0.ebuild,v 1.2 2015/06/19 07:51:32 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
inherit distutils-r1 toolchain-funcs
-DESCRIPTION="lightweight and super-fast messaging library built on top of the ZeroMQ library"
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -22,13 +22,12 @@ REQUIRED_USE="test? ( green )"
PY2_USEDEP=$(python_gen_usedep python2_7)
RDEPEND="
- >=net-libs/zeromq-4.0.5:=
+ >=net-libs/zeromq-4.1.2:=
dev-python/py[${PYTHON_USEDEP}]
dev-python/cffi:=[${PYTHON_USEDEP}]
green? ( dev-python/gevent[${PY2_USEDEP}] )"
DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/numpydoc[${PYTHON_USEDEP}]
diff --git a/dev-python/pyzmq/pyzmq-14.5.0.ebuild b/dev-python/pyzmq/pyzmq-14.7.0.ebuild
index cd5ca8d03bd5..704991ba2063 100644
--- a/dev-python/pyzmq/pyzmq-14.5.0.ebuild
+++ b/dev-python/pyzmq/pyzmq-14.7.0.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.5.0.ebuild,v 1.4 2015/05/12 14:55:14 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.7.0.ebuild,v 1.1 2015/06/19 07:51:32 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
inherit distutils-r1 toolchain-funcs
-DESCRIPTION="lightweight and super-fast messaging library built on top of the ZeroMQ library"
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -22,13 +22,12 @@ REQUIRED_USE="test? ( green )"
PY2_USEDEP=$(python_gen_usedep python2_7)
RDEPEND="
- >=net-libs/zeromq-4.0.5:=
+ >=net-libs/zeromq-4.1.2:=
dev-python/py[${PYTHON_USEDEP}]
dev-python/cffi:=[${PYTHON_USEDEP}]
green? ( dev-python/gevent[${PY2_USEDEP}] )"
DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/numpydoc[${PYTHON_USEDEP}]
diff --git a/dev-python/pyzmq/pyzmq-2.2.0.1-r1.ebuild b/dev-python/pyzmq/pyzmq-2.2.0.1-r1.ebuild
deleted file mode 100644
index 9050c2114035..000000000000
--- a/dev-python/pyzmq/pyzmq-2.2.0.1-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.2.0.1-r1.ebuild,v 1.10 2015/04/08 08:05:15 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-
-RDEPEND=">=net-libs/zeromq-2.1.9"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PY2_USEDEP}]
- dev-python/gevent[${PY2_USEDEP}]
- www-servers/tornado[${PY2_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.2.0.1-python3.patch"
-)
-
-# Configure checks write to cwd.
-# https://github.com/zeromq/pyzmq/issues/318
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- if [[ ${EPYTHON} == python3* ]]; then
- einfo "Skipping tests for ${EPYTHON}, not supported."
- else
- nosetests -svw build/lib* || die "Tests fail with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}