summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-06 22:10:34 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-06 22:10:34 +0000
commite3502eb7f667775fc52839489928192307064c4f (patch)
tree5747986eff7005112c0e81787c33ad3b4f86d7f9 /dev-python/pyzmq
parentThe old patch seemed to have incorrect line endings in it and would not apply... (diff)
downloadgentoo-2-e3502eb7f667775fc52839489928192307064c4f.tar.gz
gentoo-2-e3502eb7f667775fc52839489928192307064c4f.tar.bz2
gentoo-2-e3502eb7f667775fc52839489928192307064c4f.zip
Support Python 3. Restrict Jython ABIs. Fix dependencies. Set PYTHON_MODNAME. Fix src_test().
(Portage version: 2.2.0_alpha26_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/pyzmq-2.0.10.1.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild b/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
index a83f19eafd8b..7061cd81eea1 100644
--- a/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
+++ b/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild,v 1.1 2011/03/04 17:27:48 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.0.10.1.ebuild,v 1.2 2011/03/06 22:10:34 arfrever Exp $
EAPI="3"
-PYTHON_DEPEND="2"
+PYTHON_DEPEND="*:2.5"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
+RESTRICT_PYTHON_ABIS="2.4 *-jython"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -18,26 +19,28 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND="net-libs/zeromq
- dev-python/setuptools
- doc? ( >=dev-python/sphinx-0.6 )"
-RDEPEND=""
+RDEPEND="net-libs/zeromq"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( >=dev-python/sphinx-0.6 )"
DOCS="README.rst"
+PYTHON_MODNAME="zmq"
src_compile() {
distutils_src_compile
if use doc; then
einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
+ pushd docs > /dev/null
+# PYTHONPATH="$(ls -d ../build-$(PYTHON -f --ABI)/lib.*)" emake html || die "Generation of documentation failed"
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ popd > /dev/null
fi
}
src_test() {
testing() {
- "$(PYTHON)" setup.py build_ext --inplace
- "$(PYTHON)" setup.py test
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests -sv $(ls -d build-${PYTHON_ABI}/lib.*)
}
python_execute_function testing
}