summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-12-09 21:33:18 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-12-09 21:33:18 +0000
commite430d4b7b643c08bfdf6974d15372caa97cabcd8 (patch)
treee50885940b660db726b221d15ade218bde56bd8b /dev-python/qscintilla/qscintilla-1.6.ebuild
parentmoved to stable on x86 (diff)
downloadgentoo-2-e430d4b7b643c08bfdf6974d15372caa97cabcd8.tar.gz
gentoo-2-e430d4b7b643c08bfdf6974d15372caa97cabcd8.tar.bz2
gentoo-2-e430d4b7b643c08bfdf6974d15372caa97cabcd8.zip
version bump
(Portage version: 2.0.53)
Diffstat (limited to 'dev-python/qscintilla/qscintilla-1.6.ebuild')
-rw-r--r--dev-python/qscintilla/qscintilla-1.6.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/qscintilla/qscintilla-1.6.ebuild b/dev-python/qscintilla/qscintilla-1.6.ebuild
new file mode 100644
index 000000000000..d3f97f1444b4
--- /dev/null
+++ b/dev-python/qscintilla/qscintilla-1.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/qscintilla-1.6.ebuild,v 1.1 2005/12/09 21:33:18 carlo Exp $
+
+inherit eutils
+
+SCINTILLA_VER="1.65"
+MY_P="${PN}-${SCINTILLA_VER}-gpl-${PV}"
+MY_P=${MY_P/_pre/snapshot-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="QScintilla is a port to Qt of Neil Hodgson's Scintilla C++ editor class."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/qscintilla/"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/QScintilla/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/QScintilla/${MY_P}.tar.gz"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="=x11-libs/qt-3*"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/qt
+ sed -i -e "s:DESTDIR = \$(QTDIR)/lib:DESTDIR = \${destdir}:" qscintilla.pro
+ echo -e "\nQMAKE_CFLAGS_RELEASE=${CFLAGS} -w\nQMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w\nQMAKE_LFLAGS_RELEASE=${LDFLAGS}" >> qscintilla.pro
+ ${QTDIR}/bin/qmake -o Makefile qscintilla.pro
+
+ cd ${S}/designer
+ sed -i -e "s:LIBS += :LIBS += -L../qt :" designer.pro
+ echo -e "\nQMAKE_CFLAGS_RELEASE=${CFLAGS} -w\nQMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w\nQMAKE_LFLAGS_RELEASE=${LDFLAGS}" >> designer.pro
+ ${QTDIR}/bin/qmake -o Makefile designer.pro
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-sandbox.patch
+}
+
+src_compile() {
+ cd ${S}/qt
+ make destdir="${ROOT}/usr/$(get_libdir)" all staticlib
+ cd ${S}/designer
+ dodir ${QTDIR}/plugins/designer
+ make
+}
+
+src_install() {
+ dodoc ChangeLog LICENSE NEWS README*
+ dodir ${ROOT}/usr/{include,$(get_libdir),share/qscintilla/translations}
+ cd ${S}/qt
+ cp qextscintilla*.h "${D}/usr/include"
+ cp qscintilla*.qm "${D}/usr/share/qscintilla/translations"
+ cp libqscintilla.a* "${D}/usr/$(get_libdir)"
+ cp -d libqscintilla.so.* "${D}/usr/$(get_libdir)"
+ dodir ${QTDIR}/translations/
+ for I in $(ls -1 qscintilla*.qm) ; do
+ dosym "/usr/share/qscintilla/translations/${I}" "${QTDIR}/translations/${I}"
+ done
+ if use doc ; then
+ dohtml ${S}/doc/html/*
+ insinto /usr/share/doc/${PF}/Scintilla
+ doins ${S}/doc/Scintilla/*
+ fi
+ insinto ${QTDIR}/plugins/designer
+ insopts -m0755
+ doins ${S}/designer/libqscintillaplugin.so
+}