summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoachim Blaabjerg <styx@gentoo.org>2003-02-01 13:29:59 +0000
committerJoachim Blaabjerg <styx@gentoo.org>2003-02-01 13:29:59 +0000
commit35510048153d84b0231aee55afde5c4cf538babd (patch)
treec47e111f53803876d6ecfcf247717a8f1fc0d779 /dev-python/qscintilla
parent*** empty log message *** (diff)
downloadgentoo-2-35510048153d84b0231aee55afde5c4cf538babd.tar.gz
gentoo-2-35510048153d84b0231aee55afde5c4cf538babd.tar.bz2
gentoo-2-35510048153d84b0231aee55afde5c4cf538babd.zip
Made the ebuild install libqscintilla.a as well, by request of John Landahl.
Diffstat (limited to 'dev-python/qscintilla')
-rw-r--r--dev-python/qscintilla/ChangeLog9
-rw-r--r--dev-python/qscintilla/files/digest-qscintilla-1.49-r11
-rw-r--r--dev-python/qscintilla/files/qscintilla-1.49-sandbox.patch13
-rw-r--r--dev-python/qscintilla/qscintilla-1.49-r1.ebuild45
4 files changed, 65 insertions, 3 deletions
diff --git a/dev-python/qscintilla/ChangeLog b/dev-python/qscintilla/ChangeLog
index eac0a4d4a965..a6ec15f7108e 100644
--- a/dev-python/qscintilla/ChangeLog
+++ b/dev-python/qscintilla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/qscintilla
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/ChangeLog,v 1.4 2003/01/23 19:47:49 styx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/ChangeLog,v 1.5 2003/02/01 13:29:59 styx Exp $
+
+*qscintilla-1.49-r1 (1 Feb 2003) Joachim Blaabjerg <styx@gentoo.org>
+
+ 1 Feb 2003; Joachim Blaabjerg <styx@gentoo.org> qscintilla-1.49-r1.ebuild,
+ files/qscintilla-1.49-sandbox.patch, files/digest-qscintilla-1.49-r1 :
+
+ Made the ebuild install libqscintilla.a as well, by request of John Landahl.
21 Jan 2003; Joachim Blaabjerg <styx@gentoo.org> qscintilla-1.49.ebuild,
files/qscintilla-1.49-sandbox.patch :
diff --git a/dev-python/qscintilla/files/digest-qscintilla-1.49-r1 b/dev-python/qscintilla/files/digest-qscintilla-1.49-r1
new file mode 100644
index 000000000000..a6d0e9a2ba77
--- /dev/null
+++ b/dev-python/qscintilla/files/digest-qscintilla-1.49-r1
@@ -0,0 +1 @@
+MD5 390770238373800327d68f972397d29a qscintilla-1.49-x11-gpl-0.3.tar.gz 439774
diff --git a/dev-python/qscintilla/files/qscintilla-1.49-sandbox.patch b/dev-python/qscintilla/files/qscintilla-1.49-sandbox.patch
index de1eb95c0b0f..f43c964dac2e 100644
--- a/dev-python/qscintilla/files/qscintilla-1.49-sandbox.patch
+++ b/dev-python/qscintilla/files/qscintilla-1.49-sandbox.patch
@@ -1,5 +1,14 @@
---- Makefile.orig 2003-01-21 16:37:13.000000000 +0100
-+++ Makefile 2003-01-21 16:37:50.000000000 +0100
+--- Makefile.orig 2003-02-01 13:43:47.000000000 +0100
++++ Makefile 2003-02-01 13:44:52.000000000 +0100
+@@ -207,7 +207,7 @@
+ QMAKE_TARGET = qscintilla
+ DESTDIR = $(QTDIR)/lib/
+ TARGET = libqscintilla.so.0.0.0
+-TARGETA = $(QTDIR)/lib/libqscintilla.a
++TARGETA = libqscintilla.a
+ TARGETD = libqscintilla.so.0.0.0
+ TARGET0 = libqscintilla.so
+ TARGET1 = libqscintilla.so.0
@@ -244,11 +244,7 @@
-ln -s $(TARGET) $(TARGET0)
-ln -s $(TARGET) $(TARGET1)
diff --git a/dev-python/qscintilla/qscintilla-1.49-r1.ebuild b/dev-python/qscintilla/qscintilla-1.49-r1.ebuild
new file mode 100644
index 000000000000..8c582e7abf5f
--- /dev/null
+++ b/dev-python/qscintilla/qscintilla-1.49-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla/qscintilla-1.49-r1.ebuild,v 1.1 2003/02/01 13:29:59 styx Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${P}-x11-gpl-0.3"
+DESCRIPTION="QScintilla is a port to Qt of Neil Hodgson's Scintilla C++ editor class."
+SRC_URI="http://www.river-bank.demon.co.uk/download/QScintilla/${P}-x11-gpl-0.3.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/qscintilla/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=x11-libs/qt-3.0.4.1"
+
+src_unpack() {
+
+ unpack ${P}-x11-gpl-0.3.tar.gz
+ cd ${S}/qt
+ qmake -o Makefile qscintilla.pro
+ epatch ${FILESDIR}/${P}-sandbox.patch
+ mkdir -p ${D}/${QTDIR}/lib
+
+}
+
+src_compile() {
+
+ cd ${S}/qt
+ make all staticlib
+
+}
+
+src_install() {
+
+ cd ${S}/qt
+ mkdir -p ${D}/${QTDIR}/{include,translations,lib}
+ cp qextscintilla*.h ${D}/$QTDIR/include
+ cp qscintilla*.qm ${D}/$QTDIR/translations
+ cp libqscintilla.so.* ${D}/$QTDIR/lib
+ cp libqscintilla.a* ${D}/$QTDIR/lib
+
+}