summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-08 22:35:40 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-08 22:35:40 +0000
commit9a1c8e8cc9ed972f3eb4a76a18762b1b0314e34b (patch)
tree4d618cc9f2896dd60295aa14ea3b7f7ce956a2e4 /dev-python/rsa
parentCleanup and coding style; add (so-far not working) live ebuild (diff)
downloadgentoo-2-9a1c8e8cc9ed972f3eb4a76a18762b1b0314e34b.tar.gz
gentoo-2-9a1c8e8cc9ed972f3eb4a76a18762b1b0314e34b.tar.bz2
gentoo-2-9a1c8e8cc9ed972f3eb4a76a18762b1b0314e34b.zip
New ebuild; dependency for bug 415173.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/rsa')
-rw-r--r--dev-python/rsa/ChangeLog10
-rw-r--r--dev-python/rsa/Manifest3
-rw-r--r--dev-python/rsa/metadata.xml8
-rw-r--r--dev-python/rsa/rsa-3.0.1.ebuild26
4 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/rsa/ChangeLog b/dev-python/rsa/ChangeLog
new file mode 100644
index 000000000000..8fc0e619f08c
--- /dev/null
+++ b/dev-python/rsa/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/rsa
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rsa/ChangeLog,v 1.1 2012/05/08 22:35:40 floppym Exp $
+
+*rsa-3.0.1 (08 May 2012)
+
+ 08 May 2012; Mike Gilbert <floppym@gentoo.org> +metadata.xml,
+ +rsa-3.0.1.ebuild:
+ New ebuild; dependency for bug 415173.
+
diff --git a/dev-python/rsa/Manifest b/dev-python/rsa/Manifest
new file mode 100644
index 000000000000..f7d3cc2f6b91
--- /dev/null
+++ b/dev-python/rsa/Manifest
@@ -0,0 +1,3 @@
+DIST rsa-3.0.1.zip 49380 RMD160 5d8feb9aed2e1ab65f62dc33d66f3c0c78bdf965 SHA1 8a2ff5e1c0083e91300172e6e8d6385e9711d4f4 SHA256 2c36df5690f476154c32537b6a0a0bce85c26b4b4a365e23b6e5ac6773355668
+EBUILD rsa-3.0.1.ebuild 584 RMD160 d92e2308bb6cad954e399292d5b0d303c06ff180 SHA1 516dacfb0ecfe01dca7a35282f7d57dd72f634af SHA256 3c2a900d13d8c344de8862576a799b8254ac95e3ced04488c6105493e34d7946
+MISC metadata.xml 226 RMD160 2909536044cf6ce8818bb3c3ad01228b765e2b5e SHA1 64a2d1ef49e788e04d10fd2b628141957d3afb21 SHA256 6d279e4872052aa9bc707736a3b603153bbeaca5f31d78359ac16275a7e7f794
diff --git a/dev-python/rsa/metadata.xml b/dev-python/rsa/metadata.xml
new file mode 100644
index 000000000000..65a0ed57882b
--- /dev/null
+++ b/dev-python/rsa/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">rsa</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rsa/rsa-3.0.1.ebuild b/dev-python/rsa/rsa-3.0.1.ebuild
new file mode 100644
index 000000000000..f8c5ca727fd9
--- /dev/null
+++ b/dev-python/rsa/rsa-3.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rsa/rsa-3.0.1.ebuild,v 1.1 2012/05/08 22:35:40 floppym Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="http://stuvel.eu/rsa http://pypi.python.org/pypi/rsa"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pyasn1-0.0.13
+ >=dev-python/setuptools-0.6.10"
+DEPEND="${RDEPEND}
+ app-arch/unzip"