summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-01-02 17:59:25 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-01-02 17:59:25 +0000
commit72c1123c42fbc314ed95259769d30a58481cfd47 (patch)
tree9eb2fcb14e8a964beacf2f5b78247520d6d8e8ed /dev-python/simpletal/simpletal-3.9.ebuild
parentMove from net-zope to dev-python, bug 72252. (Manifest recommit) (diff)
downloadgentoo-2-72c1123c42fbc314ed95259769d30a58481cfd47.tar.gz
gentoo-2-72c1123c42fbc314ed95259769d30a58481cfd47.tar.bz2
gentoo-2-72c1123c42fbc314ed95259769d30a58481cfd47.zip
Move from net-zope to dev-python, bug 72252.
Diffstat (limited to 'dev-python/simpletal/simpletal-3.9.ebuild')
-rw-r--r--dev-python/simpletal/simpletal-3.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/simpletal/simpletal-3.9.ebuild b/dev-python/simpletal/simpletal-3.9.ebuild
new file mode 100644
index 000000000000..895045de08a1
--- /dev/null
+++ b/dev-python/simpletal/simpletal-3.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-3.9.ebuild,v 1.1 2005/01/02 17:56:57 kloeri Exp $
+
+IUSE=""
+
+MY_P=SimpleTAL
+
+inherit distutils
+
+DESCRIPTION="SimpleTAL is a stand alone Python implementation of the TAL, TALES and METAL specifications used in Zope to power HTML and XML templates."
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}-${PV}.tar.gz"
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/"
+DEPEND="virtual/python"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+S=${WORKDIR}/${MY_P}-${PV}
+
+src_install() {
+ distutils_src_install
+
+ docinto examples/basic
+ dodoc examples/basic/basic-example.py
+ dodoc examples/basic/basic.html
+
+ docinto examples/cgi-example
+ dodoc examples/cgi-example/simple-cgi.py
+ dodoc examples/cgi-example/fields.html
+ dodoc examples/cgi-example/results.html
+
+ docinto examples/metal-example
+ dodoc examples/metal-example/metal-example.py
+ dodoc examples/metal-example/macro.html
+ dodoc examples/metal-example/page.html
+
+ docinto examples/structure-example
+ dodoc examples/structure-example/structure-example.py
+ dodoc examples/structure-example/structure.html
+}