summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-11 17:28:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-11 17:28:58 +0000
commitae92973f374fa652d73e189019787076918d673d (patch)
tree601d8358bb9557fee158a14147fe06098e06eb29 /dev-python/sip
parentalpha/sparc stable wrt #296591 (diff)
downloadgentoo-2-ae92973f374fa652d73e189019787076918d673d.tar.gz
gentoo-2-ae92973f374fa652d73e189019787076918d673d.tar.bz2
gentoo-2-ae92973f374fa652d73e189019787076918d673d.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/sip-4.7.9.ebuild59
-rw-r--r--dev-python/sip/sip-4.9.1.ebuild75
-rw-r--r--dev-python/sip/sip-4.9.2.ebuild76
-rw-r--r--dev-python/sip/sip-4.9.3.ebuild76
4 files changed, 0 insertions, 286 deletions
diff --git a/dev-python/sip/sip-4.7.9.ebuild b/dev-python/sip/sip-4.7.9.ebuild
deleted file mode 100644
index a1ea9d8300a0..000000000000
--- a/dev-python/sip/sip-4.7.9.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.9.ebuild,v 1.7 2009/02/18 20:10:12 jer Exp $
-
-NEED_PYTHON=2.3
-
-inherit python toolchain-funcs versionator multilib
-
-MY_P=${P/_}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/sip$(get_major_version)/${MY_P}.tar.gz"
-
-LICENSE="sip"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug"
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND=""
-RDEPEND=""
-
-src_compile(){
- python_version
-
- local myconf
- use debug && myconf="${myconf} -u"
-
- "${python}" configure.py \
- -b "/usr/bin" \
- -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
- -e "/usr/include/python${PYVER}" \
- -v "/usr/share/sip" \
- ${myconf} \
- CXXFLAGS_RELEASE="" CFLAGS_RELEASE="" LFLAGS_RELEASE="" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LFLAGS="${LDFLAGS}" \
- CC=$(tc-getCC) CXX=$(tc-getCXX) \
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX) \
- STRIP="true" || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog NEWS README TODO doc/sipref.txt
- dohtml doc/*
-}
-
-pkg_postinst() {
- python_version
- python_mod_compile "$(python_get_sitedir)"/sip*.py
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}
diff --git a/dev-python/sip/sip-4.9.1.ebuild b/dev-python/sip/sip-4.9.1.ebuild
deleted file mode 100644
index 9496146f5347..000000000000
--- a/dev-python/sip/sip-4.9.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.9.1.ebuild,v 1.2 2009/11/10 17:33:32 yngwin Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python toolchain-funcs
-
-MY_P=${P/_pre/-snapshot-}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --incdir=$(python_get_includedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_need_rebuild
-
- python_execute_function -d -s
-
- dodoc ChangeLog NEWS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
- ewarn 'When updating sip, you usually need to recompile packages that'
- ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
- ewarn 'app-portage/gentoolkit installed you can find these packages with'
- ewarn '`equery d sip` and `equery d PyQt4`.'
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}
diff --git a/dev-python/sip/sip-4.9.2.ebuild b/dev-python/sip/sip-4.9.2.ebuild
deleted file mode 100644
index 89a2075da65b..000000000000
--- a/dev-python/sip/sip-4.9.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.9.2.ebuild,v 1.2 2009/11/20 15:04:40 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python toolchain-funcs
-
-MY_P=${P/_pre/-snapshot-}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --incdir=$(python_get_includedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_need_rebuild
-
- python_execute_function -d -s
-
- dodoc ChangeLog NEWS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn 'When updating sip, you usually need to recompile packages that'
- ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
- ewarn 'app-portage/gentoolkit installed you can find these packages with'
- ewarn '`equery d sip` and `equery d PyQt4`.'
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}
diff --git a/dev-python/sip/sip-4.9.3.ebuild b/dev-python/sip/sip-4.9.3.ebuild
deleted file mode 100644
index 72edaa2304d7..000000000000
--- a/dev-python/sip/sip-4.9.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.9.3.ebuild,v 1.1 2009/11/23 17:32:23 hwoarang Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python toolchain-funcs
-
-MY_P=${P/_pre/-snapshot-}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --incdir=$(python_get_includedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_need_rebuild
-
- python_execute_function -d -s
-
- dodoc ChangeLog NEWS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn 'When updating sip, you usually need to recompile packages that'
- ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
- ewarn 'app-portage/gentoolkit installed you can find these packages with'
- ewarn '`equery d sip` and `equery d PyQt4`.'
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}