summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-15 18:36:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-15 18:36:41 +0000
commit5c4d7439663319a89435f26495b09768b1db1a1e (patch)
tree117916a4f481a25780496aec8e705f0899aa6690 /dev-python/sphinx/sphinx-1.0.7.ebuild
parentBump for #351737 (diff)
downloadgentoo-2-5c4d7439663319a89435f26495b09768b1db1a1e.tar.gz
gentoo-2-5c4d7439663319a89435f26495b09768b1db1a1e.tar.bz2
gentoo-2-5c4d7439663319a89435f26495b09768b1db1a1e.zip
Version bump.
(Portage version: 2.2.0_alpha15_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sphinx/sphinx-1.0.7.ebuild')
-rw-r--r--dev-python/sphinx/sphinx-1.0.7.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/sphinx/sphinx-1.0.7.ebuild b/dev-python/sphinx/sphinx-1.0.7.ebuild
new file mode 100644
index 000000000000..403ce59f6f79
--- /dev/null
+++ b/dev-python/sphinx/sphinx-1.0.7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0.7.ebuild,v 1.1 2011/01/15 18:36:41 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Sphinx"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python documentation generator"
+HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc latex"
+
+RDEPEND=">=dev-python/docutils-0.5
+ >=dev-python/jinja-2.2
+ >=dev-python/pygments-0.8
+ latex? ( dev-texlive/texlive-latexextra )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ pushd doc > /dev/null
+ einfo "Generation of documentation"
+ PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -A txt -r doc/_build/html/* || die "Installation of documentation failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Generate the Grammar pickle to avoid sandbox violations.
+ generation_of_grammar_pickle() {
+ "$(PYTHON)" -c "import sys; sys.path.insert(0, '${EROOT}$(python_get_sitedir -b)'); from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${EROOT}$(python_get_sitedir -b)/sphinx/pycode/Grammar.txt')"
+ }
+ python_execute_function \
+ --action-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
+ --failure-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
+ generation_of_grammar_pickle
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+
+ deletion_of_grammar_pickle() {
+ rm -f "${EROOT}$(python_get_sitedir -b)/sphinx/pycode"/Grammar*.pickle || return 1
+
+ # Delete empty parent directories.
+ local dir="${EROOT}$(python_get_sitedir -b)/sphinx/pycode"
+ while [[ "${dir}" != "${EROOT%/}" ]]; do
+ rmdir "${dir}" 2> /dev/null || break
+ dir="${dir%/*}"
+ done
+ }
+ python_execute_function \
+ --action-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
+ --failure-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
+ deletion_of_grammar_pickle
+}