summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-04-17 14:53:25 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-04-17 14:53:25 +0000
commit7e28e3f84b3e85551ff6a598d772bb353d849ba3 (patch)
treee0444be4415487b02cd22e5ac01c46a91584aa89 /dev-python/spyder
parentAdd a mirror entry for bitbucket downloads. (diff)
downloadgentoo-2-7e28e3f84b3e85551ff6a598d772bb353d849ba3.tar.gz
gentoo-2-7e28e3f84b3e85551ff6a598d772bb353d849ba3.tar.bz2
gentoo-2-7e28e3f84b3e85551ff6a598d772bb353d849ba3.zip
Version bump, drop old
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog8
-rw-r--r--dev-python/spyder/spyder-2.1.2.ebuild61
-rw-r--r--dev-python/spyder/spyder-2.1.9.ebuild (renamed from dev-python/spyder/spyder-2.1.6.ebuild)2
3 files changed, 8 insertions, 63 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index 8c60afc8ef6e..4481dc61abb6 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.26 2012/03/09 09:12:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.27 2012/04/17 14:53:25 xarthisius Exp $
+
+*spyder-2.1.9 (17 Apr 2012)
+
+ 17 Apr 2012; Kacper Kowalik <xarthisius@gentoo.org> +spyder-2.1.9.ebuild,
+ -spyder-2.1.2.ebuild, -spyder-2.1.6.ebuild:
+ Version bump, drop old
*spyder-2.1.7 (09 Mar 2012)
diff --git a/dev-python/spyder/spyder-2.1.2.ebuild b/dev-python/spyder/spyder-2.1.2.ebuild
deleted file mode 100644
index 56b2450c8ff2..000000000000
--- a/dev-python/spyder/spyder-2.1.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.2.ebuild,v 1.4 2012/02/25 01:58:24 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
-
-inherit distutils eutils
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
-SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
-
-RDEPEND=">=dev-python/PyQt4-4.4[webkit]
- ipython? ( dev-python/ipython )
- matplotlib? ( dev-python/matplotlib )
- numpy? ( dev-python/numpy )
- pep8? ( dev-python/pep8 )
- pyflakes? ( >=dev-python/pyflakes-0.3 )
- pylint? ( dev-python/pylint )
- rope? ( >=dev-python/rope-0.9.3 )
- scipy? ( sci-libs/scipy )
- sphinx? ( dev-python/sphinx )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="spyderlib spyderplugins"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-disable_sphinx_dependency.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" \
- sphinx-build doc doc_output || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- doicon spyderlib/images/spyder.svg || die
- make_desktop_entry spyder Spyder spyder "Development;IDE"
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/spyder/spyder-2.1.6.ebuild b/dev-python/spyder/spyder-2.1.9.ebuild
index 70f259cee2a2..26ca0bb1dc95 100644
--- a/dev-python/spyder/spyder-2.1.6.ebuild
+++ b/dev-python/spyder/spyder-2.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.6.ebuild,v 1.3 2012/02/25 01:58:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.9.ebuild,v 1.1 2012/04/17 14:53:25 xarthisius Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"