summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-03-30 04:29:19 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-03-30 04:29:19 +0000
commita5c56b976858d3b4243deef5ac3ada41f5eb7385 (patch)
tree7e4cbdecaa07ffed6a91ffabde99ab318c4f3488 /dev-python/stevedore
parentFix e-mail address. (diff)
downloadgentoo-2-a5c56b976858d3b4243deef5ac3ada41f5eb7385.tar.gz
gentoo-2-a5c56b976858d3b4243deef5ac3ada41f5eb7385.tar.bz2
gentoo-2-a5c56b976858d3b4243deef5ac3ada41f5eb7385.zip
new bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/ChangeLog7
-rw-r--r--dev-python/stevedore/stevedore-0.15.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/stevedore/ChangeLog b/dev-python/stevedore/ChangeLog
index c27c88e1036c..272013440653 100644
--- a/dev-python/stevedore/ChangeLog
+++ b/dev-python/stevedore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/stevedore
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.13 2014/03/01 02:13:24 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.14 2014/03/30 04:29:19 prometheanfire Exp $
+
+*stevedore-0.15 (30 Mar 2014)
+
+ 30 Mar 2014; Matthew Thode <prometheanfire@gentoo.org> +stevedore-0.15.ebuild:
+ new bump
*stevedore-0.14.1 (01 Mar 2014)
diff --git a/dev-python/stevedore/stevedore-0.15.ebuild b/dev-python/stevedore/stevedore-0.15.ebuild
new file mode 100644
index 000000000000..cfd3f0b3e96f
--- /dev/null
+++ b/dev-python/stevedore/stevedore-0.15.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.15.ebuild,v 1.1 2014/03/30 04:29:19 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/dreamhost/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flake8[$(python_gen_usedep python{2_7,3_2,3_3})] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pillow[$(python_gen_usedep python{2_7,3_2,3_3})] )"
+
+python_compile_all() {
+ if use doc; then
+ mkdir docs/source/_build || die
+ sphinx-build -b html -c docs/source docs/source/ docs/source/_build
+ fi
+}
+
+python_test() {
+ nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
+ || die "Tests failed under ${EPYTHON}"
+ flake8 stevedore setup.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/. )
+ distutils-r1_python_install_all
+}