summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-19 08:23:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-19 08:23:37 +0000
commitc7681f90d768f9f6c410bbaa8600ab01bc21ecc6 (patch)
treed1da8939495335a8d3b0ef234187817c95b7864a /dev-python/stomper
parentRemove old. (diff)
downloadgentoo-2-c7681f90d768f9f6c410bbaa8600ab01bc21ecc6.tar.gz
gentoo-2-c7681f90d768f9f6c410bbaa8600ab01bc21ecc6.tar.bz2
gentoo-2-c7681f90d768f9f6c410bbaa8600ab01bc21ecc6.zip
Bump
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/stomper')
-rw-r--r--dev-python/stomper/ChangeLog7
-rw-r--r--dev-python/stomper/stomper-0.2.6.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/stomper/ChangeLog b/dev-python/stomper/ChangeLog
index 1f4db76315f4..496211e0ecdc 100644
--- a/dev-python/stomper/ChangeLog
+++ b/dev-python/stomper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/stomper
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stomper/ChangeLog,v 1.17 2013/05/20 08:42:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stomper/ChangeLog,v 1.18 2013/06/19 08:23:37 patrick Exp $
+
+*stomper-0.2.6 (19 Jun 2013)
+
+ 19 Jun 2013; Patrick Lauer <patrick@gentoo.org> +stomper-0.2.6.ebuild:
+ Bump
20 May 2013; Agostino Sarubbo <ago@gentoo.org> stomper-0.2.5.ebuild:
Stable for x86, wrt bug #470462
diff --git a/dev-python/stomper/stomper-0.2.6.ebuild b/dev-python/stomper/stomper-0.2.6.ebuild
new file mode 100644
index 000000000000..87cdb9bf454a
--- /dev/null
+++ b/dev-python/stomper/stomper-0.2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stomper/stomper-0.2.6.ebuild,v 1.1 2013/06/19 08:23:37 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+# uuid module required.
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Transport neutral client implementation of the STOMP protocol"
+HOMEPAGE="http://pypi.python.org/pypi/stomper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ delete_examples_and_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/${PN}/"{examples,tests}
+ }
+ python_execute_function -q delete_examples_and_tests
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins lib/stomper/examples/* || die "Installation of examples failed"
+ fi
+}