summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-12 08:13:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-12 08:13:42 +0000
commit1effb2189b7316596f80fe5cba3a39e2b8c13e25 (patch)
tree89ce319a5595c0dea3960c04bd3709bdb196c633 /dev-python/testresources
parentAdd py34 (diff)
downloadgentoo-2-1effb2189b7316596f80fe5cba3a39e2b8c13e25.tar.gz
gentoo-2-1effb2189b7316596f80fe5cba3a39e2b8c13e25.tar.bz2
gentoo-2-1effb2189b7316596f80fe5cba3a39e2b8c13e25.zip
Add py34
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/testresources')
-rw-r--r--dev-python/testresources/ChangeLog8
-rw-r--r--dev-python/testresources/testresources-0.2.7-r2.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/testresources/ChangeLog b/dev-python/testresources/ChangeLog
index b3da6b62f873..67655577caac 100644
--- a/dev-python/testresources/ChangeLog
+++ b/dev-python/testresources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/testresources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/ChangeLog,v 1.7 2014/06/08 09:46:15 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/ChangeLog,v 1.8 2014/06/12 08:13:42 patrick Exp $
+
+*testresources-0.2.7-r2 (12 Jun 2014)
+
+ 12 Jun 2014; Patrick Lauer <patrick@gentoo.org>
+ +testresources-0.2.7-r2.ebuild:
+ Add py34
08 Jun 2014; Akinori Hattori <hattya@gentoo.org>
testresources-0.2.7-r1.ebuild:
diff --git a/dev-python/testresources/testresources-0.2.7-r2.ebuild b/dev-python/testresources/testresources-0.2.7-r2.ebuild
new file mode 100644
index 000000000000..16e014af9415
--- /dev/null
+++ b/dev-python/testresources/testresources-0.2.7-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testresources/testresources-0.2.7-r2.ebuild,v 1.1 2014/06/12 08:13:42 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testresources, a pyunit extension for managing expensive test resources."
+HOMEPAGE="https://launchpad.net/testresources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}