summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-18 16:40:28 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-18 16:40:28 +0000
commite2c83c83713eeade22128ed22ed622e88ff90ee9 (patch)
treec81a7e4523d2dacd49f71367753c4fb298c6fa3e /dev-python/tinycss
parentapp-arch/advancecomp-1.17 masked due test failures (diff)
downloadgentoo-2-e2c83c83713eeade22128ed22ed622e88ff90ee9.tar.gz
gentoo-2-e2c83c83713eeade22128ed22ed622e88ff90ee9.tar.bz2
gentoo-2-e2c83c83713eeade22128ed22ed622e88ff90ee9.zip
migration -> distutils-r1.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/tinycss')
-rw-r--r--dev-python/tinycss/ChangeLog7
-rw-r--r--dev-python/tinycss/tinycss-0.2-r2.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/tinycss/ChangeLog b/dev-python/tinycss/ChangeLog
index 1eef0f6f4cba..09582f1c405c 100644
--- a/dev-python/tinycss/ChangeLog
+++ b/dev-python/tinycss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/tinycss
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tinycss/ChangeLog,v 1.2 2013/01/16 17:31:30 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tinycss/ChangeLog,v 1.3 2013/04/18 16:40:28 idella4 Exp $
+
+*tinycss-0.2-r2 (18 Apr 2013)
+
+ 18 Apr 2013; Ian Delaney <idella4@gentoo.org> +tinycss-0.2-r2.ebuild:
+ migration -> distutils-r1.
*tinycss-0.2-r1 (16 Jan 2013)
diff --git a/dev-python/tinycss/tinycss-0.2-r2.ebuild b/dev-python/tinycss/tinycss-0.2-r2.ebuild
new file mode 100644
index 000000000000..7ce6137fb5ce
--- /dev/null
+++ b/dev-python/tinycss/tinycss-0.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tinycss/tinycss-0.2-r2.ebuild,v 1.1 2013/04/18 16:40:27 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="http://github.com/SimonSapin/tinycss/ http://packages.python.org/tinycss/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES README.rst )
+
+python_test() {
+ export TINYCSS_SKIP_SPEEDUPS_TESTS=1
+ local test
+ for test in ${PN}/tests/test_*.py; do
+ py.test $test
+ done
+}