summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2013-08-09 15:19:42 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2013-08-09 15:19:42 +0000
commit1dc2adfefebee9f074fd6fd91c09429e64a4bd5a (patch)
treebb569b6691b48b11b2cae4a241b1cd19b8c42181 /dev-python/tracing
parentFix variable name. Add texinfo to DEPEND. (diff)
downloadgentoo-2-1dc2adfefebee9f074fd6fd91c09429e64a4bd5a.tar.gz
gentoo-2-1dc2adfefebee9f074fd6fd91c09429e64a4bd5a.tar.bz2
gentoo-2-1dc2adfefebee9f074fd6fd91c09429e64a4bd5a.zip
Bump version. Remove older versions
(Portage version: 2.2.0_alpha194/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'dev-python/tracing')
-rw-r--r--dev-python/tracing/ChangeLog8
-rw-r--r--dev-python/tracing/tracing-0.6.ebuild23
-rw-r--r--dev-python/tracing/tracing-0.7.ebuild26
-rw-r--r--dev-python/tracing/tracing-0.8.ebuild35
4 files changed, 42 insertions, 50 deletions
diff --git a/dev-python/tracing/ChangeLog b/dev-python/tracing/ChangeLog
index da8b5fcfb8be..a154606d8846 100644
--- a/dev-python/tracing/ChangeLog
+++ b/dev-python/tracing/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/tracing
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tracing/ChangeLog,v 1.4 2013/04/18 05:50:47 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tracing/ChangeLog,v 1.5 2013/08/09 15:19:42 mschiff Exp $
+
+*tracing-0.8 (09 Aug 2013)
+
+ 09 Aug 2013; Marc Schiffbauer <mschiff@gentoo.org> +tracing-0.8.ebuild,
+ -tracing-0.6.ebuild, -tracing-0.7.ebuild:
+ Bump version. Remove older versions
*tracing-0.7-r1 (18 Apr 2013)
diff --git a/dev-python/tracing/tracing-0.6.ebuild b/dev-python/tracing/tracing-0.6.ebuild
deleted file mode 100644
index 9ea5b0b384c6..000000000000
--- a/dev-python/tracing/tracing-0.6.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tracing/tracing-0.6.ebuild,v 1.1 2012/06/15 10:17:56 mschiff Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6:2.7"
-
-inherit distutils python
-
-DESCRIPTION="Debug log/trace messages"
-HOMEPAGE="http://liw.fi/tracing/"
-SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
diff --git a/dev-python/tracing/tracing-0.7.ebuild b/dev-python/tracing/tracing-0.7.ebuild
deleted file mode 100644
index 6a0f6bb73f7c..000000000000
--- a/dev-python/tracing/tracing-0.7.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tracing/tracing-0.7.ebuild,v 1.2 2012/10/07 01:37:14 mschiff Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6:2.7"
-MY_P="python-${P}"
-
-inherit distutils python
-
-DESCRIPTION="Debug log/trace messages"
-HOMEPAGE="http://liw.fi/tracing/"
-SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
diff --git a/dev-python/tracing/tracing-0.8.ebuild b/dev-python/tracing/tracing-0.8.ebuild
new file mode 100644
index 000000000000..1786667c261b
--- /dev/null
+++ b/dev-python/tracing/tracing-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tracing/tracing-0.8.ebuild,v 1.1 2013/08/09 15:19:42 mschiff Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+MY_P="python-${P}"
+
+inherit distutils-r1
+
+DESCRIPTION="Debug log/trace messages"
+HOMEPAGE="http://liw.fi/tracing/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ dodoc README
+ use doc && dohtml -r doc/_build/html/
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples/
+ insinto usr/share/doc/${PF}/examples/
+ doins example.py
+ fi
+}