summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-09 12:15:30 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-09 12:15:30 +0000
commitd69b55bba4f13d0e27bc7a26253c7ffd36607aee (patch)
treeb4fb196a955f645f1aaf54415f0239db3e2572e2 /dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
parentMigrate to twisted-r1. (diff)
downloadgentoo-2-d69b55bba4f13d0e27bc7a26253c7ffd36607aee.tar.gz
gentoo-2-d69b55bba4f13d0e27bc7a26253c7ffd36607aee.tar.bz2
gentoo-2-d69b55bba4f13d0e27bc7a26253c7ffd36607aee.zip
Fix python_prepare_all() call order.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild')
-rw-r--r--dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild b/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
index 3f27863a98ab..f30f0b15ef26 100644
--- a/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
+++ b/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild,v 1.1 2013/08/09 11:12:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild,v 1.2 2013/08/09 12:15:30 mgorny Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -20,11 +20,11 @@ DEPEND="
RDEPEND="${DEPEND}"
python_prepare_all() {
- distutils-r1_python_prepare_all
-
if [[ "${EUID}" -eq 0 ]]; then
# Disable tests failing with root permissions.
sed -e "s/test_checkKeyAsRoot/_&/" -i twisted/conch/test/test_checkers.py
sed -e "s/test_getPrivateKeysAsRoot/_&/" -i twisted/conch/test/test_openssh_compat.py
fi
+
+ distutils-r1_python_prepare_all
}