summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-08 06:59:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-08 06:59:05 +0000
commitd023eeb550d83bb9227de0a1ab47c7fadf988e50 (patch)
tree104e71860817f2a777ae74b061719e8d9b72b1d5 /dev-python/twisted-web/twisted-web-13.0.0.ebuild
parentBump (diff)
downloadgentoo-2-d023eeb550d83bb9227de0a1ab47c7fadf988e50.tar.gz
gentoo-2-d023eeb550d83bb9227de0a1ab47c7fadf988e50.tar.bz2
gentoo-2-d023eeb550d83bb9227de0a1ab47c7fadf988e50.zip
Bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/twisted-web/twisted-web-13.0.0.ebuild')
-rw-r--r--dev-python/twisted-web/twisted-web-13.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/twisted-web/twisted-web-13.0.0.ebuild b/dev-python/twisted-web/twisted-web-13.0.0.ebuild
new file mode 100644
index 000000000000..5d31dc8e252a
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-13.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-13.0.0.ebuild,v 1.1 2013/04/08 06:59:05 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.5 *-jython"
+MY_PACKAGE="Web"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
+ soap? ( dev-python/soappy )"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/plugins twisted/web"
+
+src_prepare() {
+ distutils_src_prepare
+
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+}