summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-12-29 04:15:26 +0000
committerMike Gilbert <floppym@gentoo.org>2011-12-29 04:15:26 +0000
commitb647b60a67f7f98aa56d88dea9899295c1f1c94e (patch)
treeb7771ac625179f3e9575b73eec8817b4da1907f6 /dev-python/twisted
parentDrop eutils and update HOMEPAGE, as suggested by arfrever. Remove old. (diff)
downloadgentoo-2-b647b60a67f7f98aa56d88dea9899295c1f1c94e.tar.gz
gentoo-2-b647b60a67f7f98aa56d88dea9899295c1f1c94e.tar.bz2
gentoo-2-b647b60a67f7f98aa56d88dea9899295c1f1c94e.zip
Call python_get_implementation_and_version from src_test.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog5
-rw-r--r--dev-python/twisted/twisted-11.1.0.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 69c93e37cf97..b8bfe2d86455 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/twisted
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.150 2011/12/27 06:39:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.151 2011/12/29 04:15:26 floppym Exp $
+
+ 29 Dec 2011; Mike Gilbert <floppym@gentoo.org> twisted-11.1.0.ebuild:
+ Call python_get_implementation_and_version from src_test.
*twisted-11.1.0 (27 Dec 2011)
diff --git a/dev-python/twisted/twisted-11.1.0.ebuild b/dev-python/twisted/twisted-11.1.0.ebuild
index 9f8ae4555bfb..7573a60d2f25 100644
--- a/dev-python/twisted/twisted-11.1.0.ebuild
+++ b/dev-python/twisted/twisted-11.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-11.1.0.ebuild,v 1.1 2011/12/27 06:39:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-11.1.0.ebuild,v 1.2 2011/12/29 04:15:26 floppym Exp $
EAPI="4"
PYTHON_DEPEND="2"
@@ -46,7 +46,8 @@ src_prepare(){
src_test() {
testing() {
local exit_status="0"
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests" --no-compile || die "Installation of tests failed with $(python_get_implementation) $(python_get_version)"
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install
+ --root="${T}/tests" --no-compile || die "Installation of tests failed with $(python_get_implementation_and_version)"
pushd "${T}/tests${EPREFIX}$(python_get_sitedir)" > /dev/null || die
@@ -64,7 +65,7 @@ src_test() {
if ! PYTHONPATH="." "${T}/tests${EPREFIX}/usr/bin/trial" twisted; then
if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
- die "Tests failed with $(python_get_implementation) $(python_get_version)"
+ die "Tests failed with $(python_get_implementation_and_version)"
else
exit_status="1"
fi