summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-30 14:06:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-30 14:06:30 +0000
commitc5decf7baac56ad37889b578bb1b74539f627915 (patch)
tree98d4c5a9b7e2ae444ec7019aef24f74d88b8050f /dev-python/vertex
parentVersion bump. Per bug #294153. This is non-maintainer commit. (diff)
downloadgentoo-2-c5decf7baac56ad37889b578bb1b74539f627915.tar.gz
gentoo-2-c5decf7baac56ad37889b578bb1b74539f627915.tar.bz2
gentoo-2-c5decf7baac56ad37889b578bb1b74539f627915.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/vertex')
-rw-r--r--dev-python/vertex/files/vertex-0.2.0-structlike.patch28
-rw-r--r--dev-python/vertex/vertex-0.2.0.ebuild35
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/vertex/files/vertex-0.2.0-structlike.patch b/dev-python/vertex/files/vertex-0.2.0-structlike.patch
deleted file mode 100644
index d622ac342a2e..000000000000
--- a/dev-python/vertex/files/vertex-0.2.0-structlike.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- vertex/q2q.py (revision 7162)
-+++ vertex/q2q.py (revision 7163)
-@@ -27,10 +27,8 @@
- from epsilon.extime import Time
- from epsilon import sslverify
- from epsilon import juice
-+from epsilon.structlike import record
-
--# axiom
--from axiom.slotmachine import _structlike
--
- # vertex
- from vertex import subproducer, ptcp
- from vertex import endpoint, ivertex
-@@ -2060,12 +2058,7 @@
- self.toAddress,
- self.namespace, command)
-
--class _ConnectionWaiter(_structlike):
-- __names__ = ['From',
-- 'to',
-- 'protocolName',
-- 'protocolFactory',
-- 'isClient']
-+_ConnectionWaiter = record('From to protocolName protocolFactory isClient')
-
- class Q2QClientFactory(protocol.ClientFactory):
-
diff --git a/dev-python/vertex/vertex-0.2.0.ebuild b/dev-python/vertex/vertex-0.2.0.ebuild
deleted file mode 100644
index 3c418551c246..000000000000
--- a/dev-python/vertex/vertex-0.2.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/vertex/vertex-0.2.0.ebuild,v 1.3 2009/09/06 20:28:44 idl0r Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="An implementation of the Q2Q protocol"
-HOMEPAGE="http://divmod.org/trac/wiki/DivmodVertex"
-SRC_URI="mirror://gentoo/Vertex-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~ia64 ~x86 ~amd64"
-IUSE=""
-
-DEPEND=">=dev-lang/python-2.4
- >=dev-python/twisted-2.4
- >=dev-python/pyopenssl-0.6
- >=dev-libs/openssl-0.9.7
- >=dev-python/epsilon-0.5.0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/Vertex-${PV}"
-
-DOCS="NAME.txt"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-structlike.patch"
-}
-
-src_test() {
- PYTHONPATH="." trial vertex || die "trial failed"
-}