summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-21 03:33:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-21 03:33:12 +0000
commitab4317514ccd13975e2e0edaf9753b22653578ba (patch)
tree55c74e14fe2c5c6d98d355730fe1ced3825ee5f8 /dev-python/weasyprint
parentbump; drop py2.6 add pypy suport (diff)
downloadgentoo-2-ab4317514ccd13975e2e0edaf9753b22653578ba.tar.gz
gentoo-2-ab4317514ccd13975e2e0edaf9753b22653578ba.tar.bz2
gentoo-2-ab4317514ccd13975e2e0edaf9753b22653578ba.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/ChangeLog7
-rw-r--r--dev-python/weasyprint/weasyprint-0.22.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/weasyprint/ChangeLog b/dev-python/weasyprint/ChangeLog
index 5318d50a4d9a..078743123073 100644
--- a/dev-python/weasyprint/ChangeLog
+++ b/dev-python/weasyprint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/weasyprint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.7 2014/05/08 22:20:28 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.8 2014/05/21 03:33:12 patrick Exp $
+
+*weasyprint-0.22 (21 May 2014)
+
+ 21 May 2014; Patrick Lauer <patrick@gentoo.org> +weasyprint-0.22.ebuild:
+ Bump
*weasyprint-0.21-r1 (08 May 2014)
diff --git a/dev-python/weasyprint/weasyprint-0.22.ebuild b/dev-python/weasyprint/weasyprint-0.22.ebuild
new file mode 100644
index 000000000000..b300905a80ee
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.22.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/weasyprint-0.22.ebuild,v 1.1 2014/05/21 03:33:12 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://weasyprint.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Note: specific subslot of pango since it inlines some of pango headers.
+RDEPEND="x11-libs/pango:0/0
+ media-gfx/cairosvg
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/pyphen[${PYTHON_USEDEP}]
+ "
+ # x11-libs/gdk-pixbuf # optional dep
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"