summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-06 11:30:19 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-06 11:30:19 +0000
commitbd5a4c1674ff3c16b099dc5b692cf0dcdb3fbc36 (patch)
tree5c88610f1aeca7622f9ee9ac2c62dfe2136cf697 /dev-python/webob
parentNew ebuild for jnr-unixsocket, Unix sockets for Java. Dependency of dev-java/... (diff)
downloadgentoo-2-bd5a4c1674ff3c16b099dc5b692cf0dcdb3fbc36.tar.gz
gentoo-2-bd5a4c1674ff3c16b099dc5b692cf0dcdb3fbc36.tar.bz2
gentoo-2-bd5a4c1674ff3c16b099dc5b692cf0dcdb3fbc36.zip
patch from upstream applied, fix to one tests, wrt Bug #457740 by mgorny
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/ChangeLog6
-rw-r--r--dev-python/webob/files/webob-1.2.3-tests.patch24
-rw-r--r--dev-python/webob/webob-1.2.3-r1.ebuild4
3 files changed, 32 insertions, 2 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index 13b949b35f39..693493753153 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.74 2013/04/22 07:22:56 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.75 2013/06/06 11:30:19 idella4 Exp $
+
+ 06 Jun 2013; Ian Delaney <idella4@gentoo.org> +files/webob-1.2.3-tests.patch,
+ webob-1.2.3-r1.ebuild:
+ patch from upstream applied, fix to one tests, wrt Bug #457740 by mgorny
22 Apr 2013; Ian Delaney <idella4@gentoo.org> webob-1.2.3-r1.ebuild:
drop pypy1.9 in 1.2.3-r1 due to failing testsuite
diff --git a/dev-python/webob/files/webob-1.2.3-tests.patch b/dev-python/webob/files/webob-1.2.3-tests.patch
new file mode 100644
index 000000000000..4fc3fbab7c3c
--- /dev/null
+++ b/dev-python/webob/files/webob-1.2.3-tests.patch
@@ -0,0 +1,24 @@
+From 3a2c16f2f72dbca5ddfce7f649daf426c2125fed Mon Sep 17 00:00:00 2001
+From: Aaron DeVore <aaron.devore@gmail.com>
+Date: Tue, 30 Oct 2012 11:55:30 -0700
+Subject: [PATCH] Fix issue #75: depending on dict order in test_headers2
+
+---
+ tests/test_request.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_request.py b/tests/test_request.py
+index f219d36..3e38e7a 100644
+--- a/tests/test_request.py
++++ b/tests/test_request.py
+@@ -2662,7 +2662,7 @@ def test_headers2(self):
+ self.assertTrue(i in r.headers and
+ 'HTTP_'+i.upper().replace('-', '_') in r.environ)
+ r.headers = {'Server':'Apache'}
+- self.assertEqual(list(r.environ.keys()), ['a', 'HTTP_SERVER'])
++ self.assertEqual(set(r.environ.keys()), set(['a', 'HTTP_SERVER']))
+
+ def test_host_url(self):
+ # Request has a read only property host_url that combines several
+--
+1.8.1.6
diff --git a/dev-python/webob/webob-1.2.3-r1.ebuild b/dev-python/webob/webob-1.2.3-r1.ebuild
index cca7d0814d44..5951ee4bc6de 100644
--- a/dev-python/webob/webob-1.2.3-r1.ebuild
+++ b/dev-python/webob/webob-1.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.2.3-r1.ebuild,v 1.2 2013/04/22 07:22:56 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.2.3-r1.ebuild,v 1.3 2013/06/06 11:30:19 idella4 Exp $
EAPI=5
@@ -27,6 +27,8 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
python_compile_all() {
if use doc; then
"${PYTHON}" setup.py build_sphinx || die