summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 20:08:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 20:08:29 +0000
commit606abbb703129a2f32dfadbdf48fce5694f09160 (patch)
treed4dde530802054c7f16679a605e1918fb4c3cc83 /dev-python/wtforms
parentVersion bump. (diff)
downloadgentoo-2-606abbb703129a2f32dfadbdf48fce5694f09160.tar.gz
gentoo-2-606abbb703129a2f32dfadbdf48fce5694f09160.tar.bz2
gentoo-2-606abbb703129a2f32dfadbdf48fce5694f09160.zip
Version bump.
(Portage version: 2.2_rc83_p15/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog8
-rw-r--r--dev-python/wtforms/wtforms-0.6.1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index a7cdc6c2fb2b..5220f44da073 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.6 2010/06/14 07:46:11 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.7 2010/09/17 20:08:29 arfrever Exp $
+
+*wtforms-0.6.1 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +wtforms-0.6.1.ebuild:
+ Version bump.
14 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> wtforms-0.6.ebuild:
x86 stable wrt bug #322287
diff --git a/dev-python/wtforms/wtforms-0.6.1.ebuild b/dev-python/wtforms/wtforms-0.6.1.ebuild
new file mode 100644
index 000000000000..0e2ad01754ad
--- /dev/null
+++ b/dev-python/wtforms/wtforms-0.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-0.6.1.ebuild,v 1.1 2010/09/17 20:08:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6 )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_test() {
+ cd tests
+ testing() {
+ "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}