summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-09 01:02:48 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-09 01:02:48 +0000
commitf1bb5d94b2880f4ec961048622082c5602998a41 (patch)
treee6d6cd8cd997953ccdbc37a261a45cdeab55e144 /dev-python/wxPython
parentnew wxGTK and various wxwindows apps (diff)
downloadgentoo-2-f1bb5d94b2880f4ec961048622082c5602998a41.tar.gz
gentoo-2-f1bb5d94b2880f4ec961048622082c5602998a41.tar.bz2
gentoo-2-f1bb5d94b2880f4ec961048622082c5602998a41.zip
new wxGTK and various wxwindows apps
Diffstat (limited to 'dev-python/wxPython')
-rw-r--r--dev-python/wxPython/ChangeLog7
-rw-r--r--dev-python/wxPython/Manifest4
-rw-r--r--dev-python/wxPython/files/digest-wxPython-2.4.1.21
-rw-r--r--dev-python/wxPython/wxPython-2.4.1.2.ebuild88
4 files changed, 97 insertions, 3 deletions
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index 5810f59dc228..6539e9c47a51 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.27 2003/07/08 00:58:46 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.28 2003/07/09 01:00:47 liquidx Exp $
+
+*wxPython-2.4.1.2 (09 Jul 2003)
+
+ 09 Jul 2003; Alastair Tse <liquidx@gentoo.org> wxPython-2.4.1.2.ebuild:
+ new version. needs wxGTK-2.4.1
08 Jul 2003; Alastair Tse <liquidx@gentoo.org> wxPython-2.4.0.2.ebuild:
removed non-functional patch from wxWindows-2.4.0.2
diff --git a/dev-python/wxPython/Manifest b/dev-python/wxPython/Manifest
index 96c0fa0bb5a1..976be4e4afc8 100644
--- a/dev-python/wxPython/Manifest
+++ b/dev-python/wxPython/Manifest
@@ -1,6 +1,6 @@
-MD5 61b055db57f12b6f8d1800dbeb456417 ChangeLog 4284
+MD5 f8fadd26961c1f96a9a1009f9cd72ff2 ChangeLog 4425
MD5 028027d2871c90469b2f389475c25a30 wxPython-2.4.0.7.ebuild 3117
-MD5 ca9e6bb06b7480caaae6d010a14e16d1 wxPython-2.4.1.2.ebuild 2986
+MD5 2ce81dd01f8567e67f319b8754f82c2b wxPython-2.4.1.2.ebuild 2986
MD5 3b06f1e87549af51d78bb7bfa33728b5 metadata.xml 182
MD5 88f72c81ee2c594876b3bddc9e14bb72 files/digest-wxPython-2.4.0.7 73
MD5 ce3003c042f7c8fe4700193e357ad2ad files/digest-wxPython-2.4.1.2 73
diff --git a/dev-python/wxPython/files/digest-wxPython-2.4.1.2 b/dev-python/wxPython/files/digest-wxPython-2.4.1.2
new file mode 100644
index 000000000000..00b6ca04f3cc
--- /dev/null
+++ b/dev-python/wxPython/files/digest-wxPython-2.4.1.2
@@ -0,0 +1 @@
+MD5 515fa95c5c0497404a858213b6586411 wxPythonSrc-2.4.1.2.tar.gz 12443750
diff --git a/dev-python/wxPython/wxPython-2.4.1.2.ebuild b/dev-python/wxPython/wxPython-2.4.1.2.ebuild
new file mode 100644
index 000000000000..98bec88f6a2b
--- /dev/null
+++ b/dev-python/wxPython/wxPython-2.4.1.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.1.2.ebuild,v 1.1 2003/07/09 01:00:47 liquidx Exp $
+
+IUSE="opengl gtk2"
+
+MY_P="${P/-/Src-}"
+S="${WORKDIR}/${MY_P}/${PN}"
+DESCRIPTION="A blending of the wxWindows C++ class library with Python."
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.gz"
+HOMEPAGE="http://www.wxpython.org/"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=dev-lang/python-2.1
+ =x11-libs/wxGTK-2.4.1*
+ gtk2? ( >=x11-libs/gtk+-2.0 ) : ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=dev-libs/glib-2.0 ) : ( =dev-libs/glib-1.2* )
+ opengl? ( >=dev-python/PyOpenGL-2.0.0.44 )"
+
+pkg_setup() {
+ # make sure if you want gtk2, you have wxGTK with gtk2, and vice versa
+ if [ -n "`use gtk2`" ]; then
+ if [ ! -f "/usr/bin/wxgtk2u-2.4-config" -a ! -f "/usr/bin/wxgtk2-2.4-config" ]; then
+ eerror "You need x11-libs/wxGTK compiled with GTK+2 support."
+ eerror "Either emerge wxGTK with 'gtk2' in your USE flags or"
+ eerror "emerge wxPython without 'gtk2' in your USE flags."
+ die "wxGTK needs to be compiled with gtk2"
+ fi
+ else
+ if [ ! -f "/usr/bin/wxgtk-2.4-config" ]; then
+ eerror "You need x11-libs/wxGTK compiled with GTK+1."
+ eerror "Either emerge wxGTK without 'gtk2' in your USE flags or"
+ eerror "emerge wxPython with 'gtk2' in your USE flags."
+ die "wxGTK needs to be compiled without gtk2"
+ fi
+ fi
+}
+
+src_compile() {
+ # create links so the build doesnt fail
+ #for d in ogl stc xrc gizmos ; do
+ # ln -s ${S}/../contrib/ ${S}/contrib/${d}/contrib
+ #done
+
+ #Other possible configuration variables are BUILD_OGL and BUILD_STC.
+ #BUILD_OGL builds the Object Graphics Library extension module.
+ #BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
+ #Both these variable are enabled by default. To disable them set equal to zero
+ #and add to myconf.
+ local myconf=""
+ if [ `use opengl` ]; then
+ myconf="${myconf} BUILD_GLCANVAS=1"
+ else
+ myconf="${myconf} BUILD_GLCANVAS=0"
+ fi
+
+ if [ `use gtk2` ]; then
+ myconf="${myconf} WXPORT=gtk2"
+ else
+ myconf="${myconf} WXPORT=gtk"
+ fi
+
+ python setup.py ${myconf} build || die "build failed"
+}
+
+src_install() {
+ #Other possible configuration variables are BUILD_OGL and BUILD_STC.
+ #BUILD_OGL builds the Object Graphics Library extension module.
+ #BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
+ #Both these variable are enabled by default. To disable them set equal to zero
+ #and add to myconf.
+ local myconf=""
+ if [ `use opengl` ]; then
+ myconf="${myconf} BUILD_GLCANVAS=1"
+ else
+ myconf="${myconf} BUILD_GLCANVAS=0"
+ fi
+ if [ `use gtk2` ]; then
+ myconf="${myconf} WXPORT=gtk2"
+ else
+ myconf="${myconf} WXPORT=gtk"
+ fi
+
+ python setup.py ${myconf} install --prefix=/usr --root=${D} || die
+}