summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-04-07 02:43:07 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-04-07 02:43:07 +0000
commitef6557206666bba7a5b5031dbf6bc4a1f49e03df (patch)
treefd907027dcf874981f392ad9f5834ed4d558a904 /dev-python/wxpython/wxpython-2.6.3.3.ebuild
parentMask gcj and gnustep (bug #173537). (diff)
downloadgentoo-2-ef6557206666bba7a5b5031dbf6bc4a1f49e03df.tar.gz
gentoo-2-ef6557206666bba7a5b5031dbf6bc4a1f49e03df.tar.bz2
gentoo-2-ef6557206666bba7a5b5031dbf6bc4a1f49e03df.zip
When USE="opengl" make sure wxGTK was built with opengl support.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-python/wxpython/wxpython-2.6.3.3.ebuild')
-rw-r--r--dev-python/wxpython/wxpython-2.6.3.3.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/wxpython/wxpython-2.6.3.3.ebuild b/dev-python/wxpython/wxpython-2.6.3.3.ebuild
index 28a20d1cef1f..bb3ca646c15e 100644
--- a/dev-python/wxpython/wxpython-2.6.3.3.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.3.3.ebuild,v 1.10 2007/04/04 06:00:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.3.3.ebuild,v 1.11 2007/04/07 02:43:07 dirtyepic Exp $
inherit python wxwidgets eutils multilib
@@ -31,6 +31,17 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}/wxPython/
+pkg_setup() {
+ if use opengl; then
+ if ! built_with_use wxGTK opengl; then
+ echo
+ eerror "To build wxpython with opengl support, wxGTK must also be"
+ eerror "built with USE=\"opengl\"."
+ die "Rebuild wxGTK with USE=\"opengl\""
+ fi
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"