summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-06 17:14:35 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-06 17:14:35 +0000
commite441bab75ede561b4979e59550feb7ab387e00d0 (patch)
treefaceba0d8cde15a241551325fc81ec0cad69f763 /dev-python/wxpython/wxpython-2.8.12.1.ebuild
parentx86 stable, see bug 408555 (diff)
downloadgentoo-2-e441bab75ede561b4979e59550feb7ab387e00d0.tar.gz
gentoo-2-e441bab75ede561b4979e59550feb7ab387e00d0.tar.bz2
gentoo-2-e441bab75ede561b4979e59550feb7ab387e00d0.zip
Add workaround to respect CXXFLAGS
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython/wxpython-2.8.12.1.ebuild')
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/wxpython/wxpython-2.8.12.1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
index 024f08bd51a2..c77a4a073fd5 100644
--- a/dev-python/wxpython/wxpython-2.8.12.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.13 2012/05/04 15:12:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.14 2012/05/06 17:14:35 jlec Exp $
EAPI="4"
PYTHON_DEPEND="2"
@@ -65,6 +65,9 @@ src_prepare() {
fi
python_copy_sources
+
+ # Workaround, buildsystem uses CFLAGS as CXXFLAGS
+ export CFLAGS="${CXXFLAGS}"
}
src_configure() {