summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-02-21 22:36:28 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-02-21 22:36:28 +0000
commit8f9586029ea87ea007b7211339911c60a681081c (patch)
treebd4b235342f84cdb4494da1af9379964d8a537a6 /dev-python/wxpython
parentAdd fix from upstream. (diff)
downloadgentoo-2-8f9586029ea87ea007b7211339911c60a681081c.tar.gz
gentoo-2-8f9586029ea87ea007b7211339911c60a681081c.tar.bz2
gentoo-2-8f9586029ea87ea007b7211339911c60a681081c.zip
Version bump.
Split editra out into its own package: app-editors/editra Install desktop entries for utilities. (Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog11
-rw-r--r--dev-python/wxpython/files/wxpython-2.8-drop-editra.patch49
-rw-r--r--dev-python/wxpython/files/wxpython-2.8.9-wxversion-scripts.patch191
-rw-r--r--dev-python/wxpython/wxpython-2.8.9.2.ebuild170
4 files changed, 420 insertions, 1 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index fcc049b8ec11..4c7ca47462e1 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.120 2009/02/15 19:52:50 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.121 2009/02/21 22:36:28 dirtyepic Exp $
+
+*wxpython-2.8.9.2 (21 Feb 2009)
+
+ 21 Feb 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wxpython-2.8.9-wxversion-scripts.patch,
+ +files/wxpython-2.8-drop-editra.patch, +wxpython-2.8.9.2.ebuild:
+ Version bump.
+ Split editra out into its own package: app-editors/editra
+ Install desktop entries for utilities.
15 Feb 2009; Ryan Hill <dirtyepic@gentoo.org> ChangeLog, Manifest:
Fix broken commit.
diff --git a/dev-python/wxpython/files/wxpython-2.8-drop-editra.patch b/dev-python/wxpython/files/wxpython-2.8-drop-editra.patch
new file mode 100644
index 000000000000..bd1705c62ee5
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8-drop-editra.patch
@@ -0,0 +1,49 @@
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/setup.py wxPython-src-2.8.9.2/wxPython/setup.py
+--- wxPython-src-2.8.9.2-orig/wxPython/setup.py 2009-02-21 13:13:31.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/setup.py 2009-02-21 13:14:12.000000000 -0600
+@@ -878,12 +878,6 @@ WX_PKGLIST = [ 'wx',
+ 'wx.tools',
+ 'wx.tools.XRCed',
+ 'wx.tools.XRCed.plugins',
+- 'wx.tools.Editra',
+- 'wx.tools.Editra.src',
+- 'wx.tools.Editra.src.autocomp',
+- 'wx.tools.Editra.src.eclib',
+- 'wx.tools.Editra.src.extern',
+- 'wx.tools.Editra.src.syntax',
+ ]
+
+ if not EGGing:
+@@ -910,7 +904,6 @@ else:
+ opj('scripts/pywrap'),
+ opj('scripts/pywxrc'),
+ opj('scripts/xrced'),
+- opj('scripts/editra'),
+ ]
+
+
+@@ -922,16 +915,6 @@ DATA_FILES += find_data_files('wx/tools/
+ DATA_FILES += find_data_files('wx/tools/XRCed/plugins', '*.crx')
+ DATA_FILES += find_data_files('wx/tools/XRCed/plugins/bitmaps', '*.png')
+
+-DATA_FILES += find_data_files('wx/tools/Editra/docs', '*.txt')
+-DATA_FILES += find_data_files('wx/tools/Editra/locale', '*.mo')
+-DATA_FILES += find_data_files('wx/tools/Editra/pixmaps',
+- '*.png', '*.icns', '*.ico', 'README', 'AUTHORS', 'COPYING')
+-DATA_FILES += find_data_files('wx/tools/Editra/plugins', '*.egg')
+-DATA_FILES += find_data_files('wx/tools/Editra/src', 'README')
+-DATA_FILES += find_data_files('wx/tools/Editra/styles', '*.ess')
+-DATA_FILES += find_data_files('wx/tools/Editra/tests/syntax', '*')
+-DATA_FILES += find_data_files('wx/tools/Editra', '[A-Z]*', recursive=False)
+-
+
+ ## import pprint
+ ## pprint.pprint(DATA_FILES)
+@@ -981,7 +964,6 @@ if EGGing:
+ 'pyshell = wx.py.PyShell:main',
+ 'pywrap = wx.py.PyWrap:main',
+ 'helpviewer = wx.tools.helpviewer:main',
+- 'editra = wx.tools.Editra.launcher:main',
+ 'xrced = wx.tools.XRCed.xrced:main',
+ ],
+ },
diff --git a/dev-python/wxpython/files/wxpython-2.8.9-wxversion-scripts.patch b/dev-python/wxpython/files/wxpython-2.8.9-wxversion-scripts.patch
new file mode 100644
index 000000000000..6a4567812308
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8.9-wxversion-scripts.patch
@@ -0,0 +1,191 @@
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/distrib/PyAlaMode.desktop wxPython-src-2.8.9.2/wxPython/distrib/PyAlaMode.desktop
+--- wxPython-src-2.8.9.2-orig/wxPython/distrib/PyAlaMode.desktop 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/distrib/PyAlaMode.desktop 2009-02-21 15:04:55.000000000 -0600
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=PyAlaMode
++Name=PyAlaMode (2.8)
+ Comment=GUI Python Shell with Filling and editor windows
+-Exec=pyalamode
+-Icon=PyCrust.png
++Exec=pyalamode-2.8
++Icon=/usr/share/pixmaps/PyCrust.png
+ Terminal=false
+ Type=Application
+ Categories=Application;Development;
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/distrib/PyCrust.desktop wxPython-src-2.8.9.2/wxPython/distrib/PyCrust.desktop
+--- wxPython-src-2.8.9.2-orig/wxPython/distrib/PyCrust.desktop 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/distrib/PyCrust.desktop 2009-02-21 15:06:42.000000000 -0600
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=PyCrust
++Name=PyCrust (2.8)
+ Comment=GUI Python Shell with Filling
+-Exec=pycrust
+-Icon=PyCrust.png
++Exec=pycrust-2.8
++Icon=/usr/share/pixmaps/PyCrust.png
+ Terminal=false
+ Type=Application
+ Categories=Application;Development;
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/distrib/PyShell.desktop wxPython-src-2.8.9.2/wxPython/distrib/PyShell.desktop
+--- wxPython-src-2.8.9.2-orig/wxPython/distrib/PyShell.desktop 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/distrib/PyShell.desktop 2009-02-21 15:08:19.000000000 -0600
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=PyShell
++Name=PyShell (2.8)
+ Comment=GUI Python Shell
+-Exec=pyshell
+-Icon=PyCrust.png
++Exec=pyshell-2.8
++Icon=/usr/share/pixmaps/PyCrust.png
+ Terminal=false
+ Type=Application
+ Categories=Application;Development;
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/distrib/XRCed.desktop wxPython-src-2.8.9.2/wxPython/distrib/XRCed.desktop
+--- wxPython-src-2.8.9.2-orig/wxPython/distrib/XRCed.desktop 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/distrib/XRCed.desktop 2009-02-21 15:09:22.000000000 -0600
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Name=XRCed
++Name=XRCed (2.8)
+ Comment=wxPython XRC resource editor
+-Exec=xrced
+-Icon=XRCed.png
++Exec=xrced-2.8
++Icon=/usr/share/pixmaps/XRCed.png
+ Terminal=false
+ Type=Application
+ Categories=Application;Development;
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/editra wxPython-src-2.8.9.2/wxPython/scripts/editra
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/editra 2008-02-29 14:32:17.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/editra 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.Editra.launcher import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/genaxmodule wxPython-src-2.8.9.2/wxPython/scripts/genaxmodule
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/genaxmodule 2008-02-29 14:32:17.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/genaxmodule 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.genaxmodule import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/helpviewer wxPython-src-2.8.9.2/wxPython/scripts/helpviewer
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/helpviewer 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/helpviewer 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.helpviewer import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/img2png wxPython-src-2.8.9.2/wxPython/scripts/img2png
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/img2png 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/img2png 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.img2png import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/img2py wxPython-src-2.8.9.2/wxPython/scripts/img2py
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/img2py 2008-02-29 14:32:17.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/img2py 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.img2py import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/img2xpm wxPython-src-2.8.9.2/wxPython/scripts/img2xpm
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/img2xpm 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/img2xpm 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.img2xpm import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/pyalacarte wxPython-src-2.8.9.2/wxPython/scripts/pyalacarte
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/pyalacarte 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/pyalacarte 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyAlaCarte import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/pyalamode wxPython-src-2.8.9.2/wxPython/scripts/pyalamode
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/pyalamode 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/pyalamode 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyAlaMode import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/pycrust wxPython-src-2.8.9.2/wxPython/scripts/pycrust
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/pycrust 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/pycrust 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyCrust import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/pyshell wxPython-src-2.8.9.2/wxPython/scripts/pyshell
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/pyshell 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/pyshell 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyShell import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/pywrap wxPython-src-2.8.9.2/wxPython/scripts/pywrap
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/pywrap 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/pywrap 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyWrap import main
+ main()
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/pywxrc wxPython-src-2.8.9.2/wxPython/scripts/pywxrc
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/pywxrc 2008-02-29 14:32:17.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/pywxrc 2009-02-21 15:09:58.000000000 -0600
+@@ -1,5 +1,7 @@
+ #!/usr/bin/env python
+
++import wxversion
++wxversion.select("2.8")
+ from wx.tools.pywxrc import main
+ main()
+
+diff -Naurp wxPython-src-2.8.9.2-orig/wxPython/scripts/xrced wxPython-src-2.8.9.2/wxPython/scripts/xrced
+--- wxPython-src-2.8.9.2-orig/wxPython/scripts/xrced 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.9.2/wxPython/scripts/xrced 2009-02-21 15:03:24.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.XRCed.xrced import main
+ main()
diff --git a/dev-python/wxpython/wxpython-2.8.9.2.ebuild b/dev-python/wxpython/wxpython-2.8.9.2.ebuild
new file mode 100644
index 000000000000..faf8ca4dad79
--- /dev/null
+++ b/dev-python/wxpython/wxpython-2.8.9.2.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.9.2.ebuild,v 1.1 2009/02/21 22:36:28 dirtyepic Exp $
+
+EAPI="2"
+WX_GTK_VER="2.8"
+
+inherit alternatives eutils multilib python wxwidgets flag-o-matic fdo-mime
+# We don't use distutils.eclass because it doesn't seem to play nice with
+# need-wxwidgets
+
+MY_P="${P/wxpython-/wxPython-src-}"
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2
+ doc? ( mirror://sourceforge/wxpython/wxPython-docs-${PV}.tar.bz2
+ mirror://sourceforge/wxpython/wxPython-newdocs-${PV}.tar.bz2 )
+ examples? ( mirror://sourceforge/wxpython/wxPython-demo-${PV}.tar.bz2 )"
+
+LICENSE="wxWinLL-3"
+SLOT="2.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cairo opengl doc examples"
+
+RDEPEND="
+ >=x11-libs/wxGTK-${PV}:2.8[opengl?]
+ >=dev-lang/python-2.4
+ >=x11-libs/gtk+-2.4
+ >=x11-libs/pango-1.2
+ >=dev-libs/glib-2.0
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ cairo? ( dev-python/pycairo )
+ opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/wxPython/"
+DOC_S="${WORKDIR}/wxPython-${PV}"
+
+src_prepare() {
+ sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
+
+ epatch "${FILESDIR}"/${PN}-2.8.9-wxversion-scripts.patch
+ # drop editra - we have it as a separate package now
+ epatch "${FILESDIR}"/${PN}-${SLOT}-drop-editra.patch
+
+ if use doc; then
+ cd "${DOC_S}"
+ epatch "${FILESDIR}"/${PN}-${SLOT}-cache-writable.patch
+ fi
+
+ if use examples; then
+ cd "${DOC_S}"
+ epatch "${FILESDIR}"/${PN}-${SLOT}-wxversion-demo.patch
+ fi
+}
+
+src_configure() {
+ need-wxwidgets unicode
+
+ append-flags -fno-strict-aliasing
+
+ use opengl \
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
+}
+
+src_compile() {
+ python setup.py ${mypyconf} build || die "setup.py build failed"
+}
+
+src_install() {
+ local mypyconf
+ python_version
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ use opengl \
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+ mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
+
+ python setup.py ${mypyconf} install --root="${D}" \
+ --install-purelib ${site_pkgs} || die "setup.py install failed"
+
+ # Collision protection.
+ for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth}; do
+ mv "${file}" "${file}-${SLOT}"
+ done
+
+ dodoc "${S}"/docs/{CHANGES,PyManual,README,wxPackage,wxPythonManual}.txt
+
+ insinto /usr/share/applications
+ doins "${S}"/distrib/{Py{AlaMode,Crust,Shell},XRCed}.desktop
+ insinto /usr/share/pixmaps
+ newins "${S}"/wx/py/PyCrust_32.png PyCrust.png
+ newins "${S}"/wx/tools/XRCed/XRCed_32.png XRCed.png
+
+ if use doc; then
+ dodir /usr/share/doc/${PF}/docs
+ cp -R "${DOC_S}"/docs/* "${D}"usr/share/doc/${PF}/docs/
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/demo
+ dodir /usr/share/doc/${PF}/samples
+ cp -R "${DOC_S}"/demo/* "${D}"/usr/share/doc/${PF}/demo/
+ cp -R "${DOC_S}"/samples/* "${D}"/usr/share/doc/${PF}/samples/
+ fi
+}
+
+pkg_postinst() {
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ python_mod_optimize ${site_pkgs}
+
+ fdo-mime_desktop_database_update
+
+ alternatives_auto_makesym \
+ "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym \
+ "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
+
+ echo
+ elog "Gentoo uses the Multi-version method for SLOT'ing."
+ elog "Developers, see this site for instructions on using"
+ elog "2.6 or 2.8 with your apps:"
+ elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
+ elog
+ if use doc; then
+ elog "To access the general wxWidgets documentation,"
+ elog "run /usr/share/doc/${PF}/docs/viewdocs.py"
+ elog
+ elog "wxPython documentation is available by pointing a browser"
+ elog "at /usr/share/doc/${PF}/docs/api/index.html"
+ elog
+ fi
+ if use examples; then
+ elog "The demo.py app which contains hundreds of demo modules"
+ elog "with documentation and source code has been installed at"
+ elog "/usr/share/doc/${PF}/demo/demo.py"
+ elog
+ elog "Many more example apps and modules can be found in"
+ elog "/usr/share/doc/${PF}/samples/"
+ fi
+ echo
+ ewarn "Editra is no longer packaged with wxpython in Gentoo."
+ ewarn "You can find it in the tree as app-editors/editra"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ fdo-mime_desktop_database_update
+
+ alternatives_auto_makesym \
+ "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym \
+ "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
+}