summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-02 11:10:06 +0000
committerIan Delaney <idella4@gentoo.org>2015-08-02 11:10:06 +0000
commit00d316bed6dca3369dc6c92f81b43e5cbba6d352 (patch)
tree4abcd8d14535b2ce940740990f464fdf0c545652 /dev-python
parentDrop dev-haskell/deepseq depend. ghc bundles it for a long while and we are u... (diff)
downloadgentoo-2-00d316bed6dca3369dc6c92f81b43e5cbba6d352.tar.gz
gentoo-2-00d316bed6dca3369dc6c92f81b43e5cbba6d352.tar.bz2
gentoo-2-00d316bed6dca3369dc6c92f81b43e5cbba6d352.zip
bump; set PYTHON_USEDEP fully to dependencies, delete failing doc build and install, update test phase according to changed state of failed tests, tidy of both ebuilds
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/blaze/ChangeLog10
-rw-r--r--dev-python/blaze/blaze-0.7.3.ebuild87
-rw-r--r--dev-python/blaze/blaze-0.8.0.ebuild12
-rw-r--r--dev-python/blaze/blaze-0.8.2.ebuild82
4 files changed, 95 insertions, 96 deletions
diff --git a/dev-python/blaze/ChangeLog b/dev-python/blaze/ChangeLog
index 5e8e51116c16..95b6f19cee3b 100644
--- a/dev-python/blaze/ChangeLog
+++ b/dev-python/blaze/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/blaze
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/ChangeLog,v 1.22 2015/06/28 17:56:52 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/ChangeLog,v 1.23 2015/08/02 11:10:06 idella4 Exp $
+
+*blaze-0.8.2 (02 Aug 2015)
+
+ 02 Aug 2015; Ian Delaney <idella4@gentoo.org> +blaze-0.8.2.ebuild,
+ -blaze-0.7.3.ebuild, blaze-0.8.0.ebuild:
+ bump; set PYTHON_USEDEP fully to dependencies, delete failing doc build and
+ install, update test phase according to changed state of failed tests, tidy of
+ both ebuilds
28 Jun 2015; Patrice Clement <monsieurp@gentoo.org> blaze-0.8.0.ebuild:
Update numba dependency to satisfy dependencies resolution and get the tree
diff --git a/dev-python/blaze/blaze-0.7.3.ebuild b/dev-python/blaze/blaze-0.7.3.ebuild
deleted file mode 100644
index 1616b675fdf3..000000000000
--- a/dev-python/blaze/blaze-0.7.3.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.7.3.ebuild,v 1.1 2015/03/17 07:02:36 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-# Tests attempt to import mystery modules in datashape
-RESTRICT="test"
-
-inherit distutils-r1
-
-DESCRIPTION="Next generation Python numpy"
-HOMEPAGE="http://blaze.pydata.org/"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-# Currently doc build fails, reason now, attempt to import mystery modules in datashape
-# Leaving doc build content in case this is fixed
-IUSE="doc examples test"
-
-# pyspark appears an optional dep not in portage. pyskit appears to be dropped
-# pyparsing looks to be required still despite its absence from requirements.txt
-PY2_USEDEP=$(python_gen_usedep python2_7)
-RDEPEND="
- >=dev-python/blz-0.6.2[${PYTHON_USEDEP}]
- =dev-python/datashape-0.4*[${PYTHON_USEDEP}]
- >=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- dev-python/cytoolz[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/unicodecsv[${PY2_USEDEP}]
- >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- >=dev-python/flask-0.10.1[${PY2_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/pytables[${PYTHON_USEDEP}]
- dev-python/pymongo[${PYTHON_USEDEP}]
- dev-python/xlrd[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/into[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numba[${PYTHON_USEDEP}]
- dev-python/bcolz[${PYTHON_USEDEP}]
- "
-DEPEND="
- >=dev-python/cython-0.18[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- dev-python/bokeh[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
- dev-python/pyyaml[${PYTHON_USEDEP}] )
- "
-# Currently doc build fails, reason unclear but appears it's tied to use of
-# redhat's anaconda installer, seemingly hostile to gentoo.
-
-python_prepare_all() {
- # Prevent d'loading. Use this for now. Flagged for improved fix later.
- sed -e "s: 'sphinx.ext.intersphinx',::" -i docs/source/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-#python_compile_all() {
-# use doc && emake -C docs html
-#}
-
-python_test() {
- # https://github.com/ContinuumIO/blaze/issues/791
- cd "${BUILD_DIR}"/lib || die
- "${PYTHON}" -c 'import blaze; blaze.test()' || die
-}
-
-python_install_all() {
-# use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( blaze/examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/blaze/blaze-0.8.0.ebuild b/dev-python/blaze/blaze-0.8.0.ebuild
index 477c3322e643..84f0871fe8bb 100644
--- a/dev-python/blaze/blaze-0.8.0.ebuild
+++ b/dev-python/blaze/blaze-0.8.0.ebuild
@@ -1,14 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.8.0.ebuild,v 1.2 2015/06/28 17:56:52 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.8.0.ebuild,v 1.3 2015/08/02 11:10:06 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-# Tests attempt to import mystery modules in datashape
-#RESTRICT="test"
-
inherit distutils-r1
DESCRIPTION="Next generation Python numpy"
@@ -24,9 +21,8 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
# pyspark appears an optional dep not in portage. pyskit appears to be dropped
-# some p0ackages including pyparsing appear required despite their absence from requirements.txt
+# some packages including pyparsing appear required despite their absence from requirements.txt
-PY2_USEDEP=$(python_gen_usedep python2_7)
RDEPEND="
<dev-python/datashape-0.4.4[${PYTHON_USEDEP}]
>=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
@@ -36,10 +32,10 @@ RDEPEND="
dev-python/cytoolz[${PYTHON_USEDEP}]
>=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/unicodecsv[${PY2_USEDEP}]
+ dev-python/unicodecsv[${PYTHON_USEDEP}]
>=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/flask-0.10.1[${PY2_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
>=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
>=dev-python/pymongo-2.8[${PYTHON_USEDEP}]
diff --git a/dev-python/blaze/blaze-0.8.2.ebuild b/dev-python/blaze/blaze-0.8.2.ebuild
new file mode 100644
index 000000000000..ca6c4971fb22
--- /dev/null
+++ b/dev-python/blaze/blaze-0.8.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blaze/blaze-0.8.2.ebuild,v 1.1 2015/08/02 11:10:06 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Next generation Python numpy"
+HOMEPAGE="http://blaze.pydata.org/"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# Currently doc build fails, reason now, attempt to import mystery modules in datashape
+# Leaving doc build content in case this is fixed
+IUSE="examples test"
+
+# pyspark appears an optional dep not in portage. pyskit appears to be dropped
+# some packages including pyparsing appear required despite their absence from requirements.txt
+
+RDEPEND="
+ <dev-python/datashape-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/cytoolz[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/unicodecsv[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-2.8[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/into[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/bcolz[${PYTHON_USEDEP}]
+ >=dev-python/odo-0.3.1[${PYTHON_USEDEP}]"
+DEPEND="
+ >=dev-python/cython-0.18[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}] )
+ "
+# It was found on testing that dev-python/chardet is required for tests
+# despite not being inlcuded in requirements.txt
+# The doc build now fails due to dep bokeh failing to emerge. Deleted.
+
+python_test() {
+ # https://github.com/ContinuumIO/blaze/issues/1117
+ # skip test requiring a server daemon
+ # Tally of known failure reduced to one under py2.7 (test_highly_nested_repr)
+ # and 2 under py3. The failure of test_query_with_strings persists
+ # under python3 and appears to be unaddressed upstream.
+ # Changes in the suite in this version require PYTHONPATH set to ${S}
+ # to avoid spurious errors resulting from the change of path set by the eclass.
+
+ einfo "The test suite has 4 additional failures with package numba installed"
+ einfo "Upstream have been informed via /blaze/issues/1117 @ github.com/"
+ einfo "For optimum results, uninstall numba, but it counters protocol to exclude"
+ einfo "dev-python/numba from dependencies in the ebuild"
+
+ PYTHONPATH="${S}" py.test --ignore blaze/compute/tests/test_mongo_compute.py blaze \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( blaze/examples/. )
+
+ distutils-r1_python_install_all
+}