summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-01-09 01:24:26 +0000
committerDavide Pesavento <pesa@gentoo.org>2015-01-09 01:24:26 +0000
commit090e21bdd84ed3c91b294f749cc5bd19f9c79b62 (patch)
tree4a1956949b3f125e8c57448c60a2211594765dab /dev-python
parentold (diff)
downloadgentoo-2-090e21bdd84ed3c91b294f749cc5bd19f9c79b62.tar.gz
gentoo-2-090e21bdd84ed3c91b294f749cc5bd19f9c79b62.tar.bz2
gentoo-2-090e21bdd84ed3c91b294f749cc5bd19f9c79b62.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt5/ChangeLog10
-rw-r--r--dev-python/PyQt5/PyQt5-5.4.ebuild (renamed from dev-python/PyQt5/PyQt5-5.3.2.ebuild)52
-rw-r--r--dev-python/PyQt5/files/PyQt5-5.3.2-add-dep-to-QtWebKitWidgets.patch11
3 files changed, 27 insertions, 46 deletions
diff --git a/dev-python/PyQt5/ChangeLog b/dev-python/PyQt5/ChangeLog
index 072eddc765a8..38084f144133 100644
--- a/dev-python/PyQt5/ChangeLog
+++ b/dev-python/PyQt5/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt5
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt5/ChangeLog,v 1.4 2014/10/24 16:37:59 axs Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt5/ChangeLog,v 1.5 2015/01/09 01:24:26 pesa Exp $
+
+*PyQt5-5.4 (09 Jan 2015)
+
+ 09 Jan 2015; Davide Pesavento <pesa@gentoo.org> +PyQt5-5.4.ebuild,
+ -PyQt5-5.3.2.ebuild, -files/PyQt5-5.3.2-add-dep-to-QtWebKitWidgets.patch:
+ Version bump.
24 Oct 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+files/PyQt5-5.3.2-add-dep-to-QtWebKitWidgets.patch, PyQt5-5.3.2.ebuild:
diff --git a/dev-python/PyQt5/PyQt5-5.3.2.ebuild b/dev-python/PyQt5/PyQt5-5.4.ebuild
index 5961914e173f..2a2cce9b1e19 100644
--- a/dev-python/PyQt5/PyQt5-5.3.2.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt5/PyQt5-5.3.2.ebuild,v 1.4 2014/10/24 16:37:59 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt5/PyQt5-5.4.ebuild,v 1.1 2015/01/09 01:24:26 pesa Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/ https://pypi.
MY_PN="PyQt-gpl"
if [[ ${PV} == *_pre* ]]; then
MY_P=${MY_PN}-${PV%_pre*}-snapshot-${REVISION}
- SRC_URI="http://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+ SRC_URI="http://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.xz"
else
MY_P=${MY_PN}-${PV}
SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
@@ -23,7 +23,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# TODO: bluetooth
+# TODO: bluetooth, webchannel, webengine
IUSE="dbus debug declarative designer doc examples +gui help multimedia network opengl positioning
printsupport sensors serialport sql svg testlib webkit websockets widgets x11extras xmlpatterns"
REQUIRED_USE="
@@ -41,7 +41,7 @@ QT_PV="5.3.2:5"
RDEPEND="
${PYTHON_DEPS}
- >=dev-python/sip-4.16:=[${PYTHON_USEDEP}]
+ >=dev-python/sip-4.16.4:=[${PYTHON_USEDEP}]
>=dev-qt/qtcore-${QT_PV}
>=dev-qt/qtxml-${QT_PV}
dbus? (
@@ -75,21 +75,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
- if ! use dbus; then
- sed -i -e '/^\s\+check_dbus(/d' configure.py || die
- fi
-
- epatch "${FILESDIR}"/${P}-add-dep-to-QtWebKitWidgets.patch
- python_copy_sources
-
- preparation() {
- if [[ ${EPYTHON} == python3.* ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_foreach_impl run_in_build_dir preparation
+ # Avoid automagic dependency.
+ use dbus || rm -fr dbus
}
pyqt_use_enable() {
@@ -99,7 +86,8 @@ pyqt_use_enable() {
src_configure() {
configuration() {
local myconf=(
- "${PYTHON}" configure.py
+ "${PYTHON}"
+ "${S}"/configure.py
--confirm-license
--qmake="${EPREFIX}/usr/$(get_libdir)/qt5/bin/qmake"
--destdir="$(python_get_sitedir)"
@@ -108,6 +96,7 @@ src_configure() {
--qsci-api
$(use debug && echo --debug)
--enable=QtCore
+ --enable=QtXml
$(pyqt_use_enable dbus QtDBus)
$(pyqt_use_enable declarative QtQml)
$(pyqt_use_enable declarative QtQuick)
@@ -138,17 +127,9 @@ src_configure() {
echo "${myconf[@]}"
"${myconf[@]}" || die
- # We need to specify the .pro file name when it doesn't follow
- # the subdirs naming convention or recursive qmake won't work.
- sed -i -e '/^SUBDIRS/ {
- s:designer:designer/python.pro:
- s:pylupdate:pylupdate/pylupdate5.pro:
- s:pyrcc:pyrcc/pyrcc5.pro:
- s:qmlscene:qmlscene/python.pro:
- }' ${PN}.pro || die
eqmake5 -recursive ${PN}.pro
}
- python_parallel_foreach_impl run_in_build_dir configuration
+ python_foreach_impl run_in_build_dir configuration
}
src_compile() {
@@ -158,9 +139,14 @@ src_compile() {
src_install() {
installation() {
local tmp_root=${D%/}/tmp
+ emake INSTALL_ROOT="${tmp_root}" install
- # INSTALL_ROOT is used by designer/Makefile, other Makefiles use DESTDIR.
- emake DESTDIR="${tmp_root}" INSTALL_ROOT="${tmp_root}" install
+ local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
+ if python_is_python3; then
+ rm -r "${uic_dir}"/port_v2 || die
+ else
+ rm -r "${uic_dir}"/port_v3 || die
+ fi
python_doexe "${tmp_root}${EPREFIX}"/usr/bin/pyuic5
rm "${tmp_root}${EPREFIX}"/usr/bin/pyuic5 || die
@@ -170,7 +156,7 @@ src_install() {
}
python_foreach_impl run_in_build_dir installation
- dodoc NEWS
+ dodoc ChangeLog NEWS
if use doc; then
dodoc -r doc/html
diff --git a/dev-python/PyQt5/files/PyQt5-5.3.2-add-dep-to-QtWebKitWidgets.patch b/dev-python/PyQt5/files/PyQt5-5.3.2-add-dep-to-QtWebKitWidgets.patch
deleted file mode 100644
index 739cf2770057..000000000000
--- a/dev-python/PyQt5/files/PyQt5-5.3.2-add-dep-to-QtWebKitWidgets.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- PyQt-gpl-5.3.1/configure.py 2014-07-04 11:09:11.000000000 +0200
-+++ PyQt-gpl-5.3.1.new/configure.py 2014-09-09 03:13:52.351527684 +0200
-@@ -86,7 +86,7 @@ MODULE_METADATA = {
- 'QtSvg': ModuleMetadata(qmake_QT=['svg']),
- 'QtTest': ModuleMetadata(qmake_QT=['testlib', 'widgets']),
- 'QtWebKit': ModuleMetadata(qmake_QT=['webkit', 'network']),
-- 'QtWebKitWidgets': ModuleMetadata(qmake_QT=['webkitwidgets']),
-+ 'QtWebKitWidgets': ModuleMetadata(qmake_QT=['webkitwidgets', 'printsupport']),
- 'QtWebSockets': ModuleMetadata(qmake_QT=['websockets']),
- 'QtWidgets': ModuleMetadata(qmake_QT=['widgets']),
- 'QtWinExtras': ModuleMetadata(qmake_QT=['winextras', 'widgets']),