summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-31 16:18:46 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-31 16:18:46 +0000
commit1810eb951202eee06c356673eebad56b24dbafe7 (patch)
tree42e15b1b195f6f1a543fa8586ffe075f8ef9147d /dev-python
parentConvert to python-r1. (diff)
downloadgentoo-2-1810eb951202eee06c356673eebad56b24dbafe7.tar.gz
gentoo-2-1810eb951202eee06c356673eebad56b24dbafe7.tar.bz2
gentoo-2-1810eb951202eee06c356673eebad56b24dbafe7.zip
Convert to distutils-r1.
(Portage version: 2.2.1_p7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyalsa/ChangeLog7
-rw-r--r--dev-python/pyalsa/pyalsa-1.0.26-r1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/pyalsa/ChangeLog b/dev-python/pyalsa/ChangeLog
index 043a1aa26c4a..49973bcccfe6 100644
--- a/dev-python/pyalsa/ChangeLog
+++ b/dev-python/pyalsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyalsa
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyalsa/ChangeLog,v 1.36 2013/05/01 13:20:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyalsa/ChangeLog,v 1.37 2013/08/31 16:18:46 mgorny Exp $
+
+*pyalsa-1.0.26-r1 (31 Aug 2013)
+
+ 31 Aug 2013; Michał Górny <mgorny@gentoo.org> +pyalsa-1.0.26-r1.ebuild:
+ Convert to distutils-r1.
01 May 2013; Samuli Suominen <ssuominen@gentoo.org> -pyalsa-1.0.22.ebuild,
-pyalsa-1.0.24.ebuild, -pyalsa-1.0.25.ebuild:
diff --git a/dev-python/pyalsa/pyalsa-1.0.26-r1.ebuild b/dev-python/pyalsa/pyalsa-1.0.26-r1.ebuild
new file mode 100644
index 000000000000..f2528cd3d9c7
--- /dev/null
+++ b/dev-python/pyalsa/pyalsa-1.0.26-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyalsa/pyalsa-1.0.26-r1.ebuild,v 1.1 2013/08/31 16:18:46 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for ALSA library"
+HOMEPAGE="http://alsa-project.org/"
+SRC_URI="mirror://alsaproject/pyalsa/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-1.0.25-no-build-symlinks.patch"
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # note: this needs changing when py3 becomes supported
+ append-flags -fno-strict-aliasing
+}