summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-14 04:38:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-14 04:38:55 +0000
commit250ff1f4ae7cd7ef473ac2063b33134146613d73 (patch)
treee932fe5ca8e8fb07de65512e4e57e34275fdb804 /dev-python
parentBump, some new deps (diff)
downloadgentoo-2-250ff1f4ae7cd7ef473ac2063b33134146613d73.tar.gz
gentoo-2-250ff1f4ae7cd7ef473ac2063b33134146613d73.tar.bz2
gentoo-2-250ff1f4ae7cd7ef473ac2063b33134146613d73.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libcloud/ChangeLog7
-rw-r--r--dev-python/libcloud/libcloud-0.15.0.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/libcloud/ChangeLog b/dev-python/libcloud/ChangeLog
index 1bec04fd2640..eec4584b68b7 100644
--- a/dev-python/libcloud/ChangeLog
+++ b/dev-python/libcloud/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/libcloud
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.16 2014/05/28 07:28:11 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.17 2014/07/14 04:38:55 patrick Exp $
+
+*libcloud-0.15.0 (14 Jul 2014)
+
+ 14 Jul 2014; Patrick Lauer <patrick@gentoo.org> +libcloud-0.15.0.ebuild:
+ Bump
28 May 2014; Dirkjan Ochtman <djc@gentoo.org> -libcloud-0.12.4-r1.ebuild,
-libcloud-0.13.2.ebuild:
diff --git a/dev-python/libcloud/libcloud-0.15.0.ebuild b/dev-python/libcloud/libcloud-0.15.0.ebuild
new file mode 100644
index 000000000000..9de44d4d2e5a
--- /dev/null
+++ b/dev-python/libcloud/libcloud-0.15.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.15.0.ebuild,v 1.1 2014/07/14 04:38:55 patrick Exp $
+
+EAPI=5
+
+# py3 dropped due to failing tests once lockfile installed
+PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy pypy2_0 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}