summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-06 11:37:11 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-06 11:37:11 +0000
commit278a37d287f414b2e25bafd1f1a82fd65e35430e (patch)
tree140925254ed90357872077ab9b123eb952eab514 /dev-python
parentbump; not py3 ready, converted to new eclass, rm old (diff)
downloadgentoo-2-278a37d287f414b2e25bafd1f1a82fd65e35430e.tar.gz
gentoo-2-278a37d287f414b2e25bafd1f1a82fd65e35430e.tar.bz2
gentoo-2-278a37d287f414b2e25bafd1f1a82fd65e35430e.zip
dev-python/pytest-runner: Version Bump, add pypy3 support
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-runner/ChangeLog8
-rw-r--r--dev-python/pytest-runner/files/pytest-runner-2.1.2-hgtools.patch17
-rw-r--r--dev-python/pytest-runner/metadata.xml12
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.1.2.ebuild25
4 files changed, 55 insertions, 7 deletions
diff --git a/dev-python/pytest-runner/ChangeLog b/dev-python/pytest-runner/ChangeLog
index 97c38c04f580..f739e11434ee 100644
--- a/dev-python/pytest-runner/ChangeLog
+++ b/dev-python/pytest-runner/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pytest-runner
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-runner/ChangeLog,v 1.8 2014/11/06 08:25:52 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-runner/ChangeLog,v 1.9 2014/12/06 11:37:11 jlec Exp $
+
+*pytest-runner-2.1.2 (06 Dec 2014)
+
+ 06 Dec 2014; Justin Lecher <jlec@gentoo.org> +pytest-runner-2.1.2.ebuild,
+ +files/pytest-runner-2.1.2-hgtools.patch, metadata.xml:
+ Version Bump, add pypy3 support
06 Nov 2014; Ian Delaney <idella4@gentoo.org> pytest-runner-1.1-r1.ebuild:
clean old impls, add py3.4 support
diff --git a/dev-python/pytest-runner/files/pytest-runner-2.1.2-hgtools.patch b/dev-python/pytest-runner/files/pytest-runner-2.1.2-hgtools.patch
new file mode 100644
index 000000000000..1d379e18f600
--- /dev/null
+++ b/dev-python/pytest-runner/files/pytest-runner-2.1.2-hgtools.patch
@@ -0,0 +1,17 @@
+ setup.py | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 2679782..271b3cf 100644
+--- a/setup.py
++++ b/setup.py
+@@ -26,9 +26,6 @@ setup_params = dict(
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ ],
+- setup_requires=[
+- 'hgtools',
+- ],
+ )
+ if __name__ == '__main__':
+ setuptools.setup(**setup_params)
diff --git a/dev-python/pytest-runner/metadata.xml b/dev-python/pytest-runner/metadata.xml
index f0eec1657131..867989d75d43 100644
--- a/dev-python/pytest-runner/metadata.xml
+++ b/dev-python/pytest-runner/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <maintainer>
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <longdescription lang="en">
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
Adds support for tests during installation of setup.py files.
</longdescription>
</pkgmetadata>
diff --git a/dev-python/pytest-runner/pytest-runner-2.1.2.ebuild b/dev-python/pytest-runner/pytest-runner-2.1.2.ebuild
new file mode 100644
index 000000000000..e159b7e3bdc7
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-2.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-runner/pytest-runner-2.1.2.ebuild,v 1.1 2014/12/06 11:37:11 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests durring installation of setup.py files"
+HOMEPAGE="http://pypi.python.org/pypi/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hgtools.patch
+)