summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-10 01:27:16 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-10 01:27:16 +0000
commit4ca2054b5683505074c6094a6bfb74f9fa9a4fd7 (patch)
tree01efa2556f25edd051517d8505e0fca866b85215 /dev-python
parentBump to EAPI=5 (bug #478714) (diff)
downloadgentoo-2-4ca2054b5683505074c6094a6bfb74f9fa9a4fd7.tar.gz
gentoo-2-4ca2054b5683505074c6094a6bfb74f9fa9a4fd7.tar.bz2
gentoo-2-4ca2054b5683505074c6094a6bfb74f9fa9a4fd7.zip
switch test dep to pytest, update test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/datashape/ChangeLog5
-rw-r--r--dev-python/datashape/datashape-0.3.0.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/datashape/ChangeLog b/dev-python/datashape/ChangeLog
index 9cd4c3d38baa..80f93fe58e27 100644
--- a/dev-python/datashape/ChangeLog
+++ b/dev-python/datashape/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/datashape
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.4 2014/08/09 08:29:27 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.5 2014/08/10 01:27:16 idella4 Exp $
+
+ 10 Aug 2014; Ian Delaney <idella4@gentoo.org> datashape-0.3.0.ebuild:
+ switch test dep to pytest, update test phase
*datashape-0.3.0 (09 Aug 2014)
diff --git a/dev-python/datashape/datashape-0.3.0.ebuild b/dev-python/datashape/datashape-0.3.0.ebuild
index 3f7d19d727ef..3694bd5106ec 100644
--- a/dev-python/datashape/datashape-0.3.0.ebuild
+++ b/dev-python/datashape/datashape-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.3.0.ebuild,v 1.1 2014/08/09 08:29:27 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.3.0.ebuild,v 1.2 2014/08/10 01:27:16 idella4 Exp $
EAPI=5
@@ -24,7 +24,7 @@ RDEPEND="
"
DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )"
+ dev-python/pytest[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Prevent un-needed d'loading
@@ -38,9 +38,7 @@ python_compile_all() {
}
python_test() {
- # https://github.com/ContinuumIO/datashape/issues/78
- cd "${BUILD_DIR}"/lib* || die
- nosetests -v || die
+ py.test -v || die "Tests failed under ${EPYTHON}"
}
python_install_all() {