summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-27 00:37:27 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-27 00:37:27 +0000
commit505b56abca28c41eacc70c68558694985e0dc857 (patch)
treef851e70851fd42df69a4ff31dbbee3b7e9134c7f /dev-python
parentupdating sqlalchemy deps (diff)
downloadgentoo-2-505b56abca28c41eacc70c68558694985e0dc857.tar.gz
gentoo-2-505b56abca28c41eacc70c68558694985e0dc857.tar.bz2
gentoo-2-505b56abca28c41eacc70c68558694985e0dc857.zip
bump; drop py2.6, upgrade test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bsddb3/ChangeLog7
-rw-r--r--dev-python/bsddb3/bsddb3-6.1.0.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-python/bsddb3/ChangeLog b/dev-python/bsddb3/ChangeLog
index cd0ecd287919..d7ae9e2387f5 100644
--- a/dev-python/bsddb3/ChangeLog
+++ b/dev-python/bsddb3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bsddb3
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.105 2014/07/16 10:08:51 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.106 2014/07/27 00:37:27 idella4 Exp $
+
+*bsddb3-6.1.0 (27 Jul 2014)
+
+ 27 Jul 2014; Ian Delaney <idella4@gentoo.org> +bsddb3-6.1.0.ebuild:
+ bump; drop py2.6, upgrade test phase
16 Jul 2014; Pacho Ramos <pacho@gentoo.org> bsddb3-6.0.1.ebuild:
amd64/x86 stable, bug #516176
diff --git a/dev-python/bsddb3/bsddb3-6.1.0.ebuild b/dev-python/bsddb3/bsddb3-6.1.0.ebuild
new file mode 100644
index 000000000000..fff2cceb05f3
--- /dev/null
+++ b/dev-python/bsddb3/bsddb3-6.1.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-6.1.0.ebuild,v 1.1 2014/07/27 00:37:27 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit db-use distutils-r1 multilib
+
+DESCRIPTION="Python bindings for Berkeley DB"
+HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm http://pypi.python.org/pypi/bsddb3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=sys-libs/db-4.8.30
+ <sys-libs/db-6.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # This list should be kept in sync with setup.py.
+ for DB_VER in 6.0 5.3 5.2 5.1 5.0 4.8; do
+ has_version "sys-libs/db:${DB_VER}" && break
+ done
+
+ # Force version.
+ sed -e "s/db_ver = None/db_ver = (${DB_VER%.*}, ${DB_VER#*.})/" \
+ -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
+ -i setup2.py setup3.py || die
+
+ # Adjust test.py to look in build/lib.
+ sed -e "s/'lib.%s' % PLAT_SPEC/'lib'/" \
+ -i test2.py test3.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ # These are needed for both build and install.
+ export BERKELEYDB_DIR="${EPREFIX}/usr"
+ export BERKELEYDB_INCDIR="${EPREFIX}$(db_includedir)"
+ export BERKELEYDB_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ if python_is_python3; then
+ PYTHONPATH=Lib3 "${PYTHON}" test3.py -v || die "Testing failed with ${EPYTHON}"
+ else
+ PYTHONPATH=Lib "${PYTHON}" test.py -v || die "Testing failed with ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/html/. )
+ distutils-r1_python_install_all
+}