summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-10-13 15:42:21 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-10-13 15:42:21 +0000
commit5a70cf66eda09720b5cb88d3230cf50cf562e8bf (patch)
tree95205d880baf4b28906f5bdcac6b17028bcce405 /dev-python
parentmutter and muffin are also compatible with this themes (diff)
downloadgentoo-2-5a70cf66eda09720b5cb88d3230cf50cf562e8bf.tar.gz
gentoo-2-5a70cf66eda09720b5cb88d3230cf50cf562e8bf.tar.bz2
gentoo-2-5a70cf66eda09720b5cb88d3230cf50cf562e8bf.zip
add version 0.20.0
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/websocket-client/ChangeLog8
-rw-r--r--dev-python/websocket-client/websocket-client-0.20.0.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/websocket-client/ChangeLog b/dev-python/websocket-client/ChangeLog
index d29c1a4a6d7b..ca81caccc727 100644
--- a/dev-python/websocket-client/ChangeLog
+++ b/dev-python/websocket-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/websocket-client
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/websocket-client/ChangeLog,v 1.2 2014/08/31 01:53:22 alunduil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/websocket-client/ChangeLog,v 1.3 2014/10/13 15:42:21 alunduil Exp $
+
+*websocket-client-0.20.0 (13 Oct 2014)
+
+ 13 Oct 2014; Alex Brandt <alunduil@gentoo.org>
+ +websocket-client-0.20.0.ebuild:
+ add version 0.20.0
31 Aug 2014; Alex Brandt <alunduil@gentoo.org> websocket-client-0.11.0.ebuild,
websocket-client-0.17.0.ebuild:
diff --git a/dev-python/websocket-client/websocket-client-0.20.0.ebuild b/dev-python/websocket-client/websocket-client-0.20.0.ebuild
new file mode 100644
index 000000000000..332fde059f44
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-0.20.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/websocket-client/websocket-client-0.20.0.ebuild,v 1.1 2014/10/13 15:42:21 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="WebSocket client for python. hybi13 is supported"
+HOMEPAGE="https://github.com/liris/websocket-client"
+SRC_URI="https://github.com/liris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2*' )
+"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}