summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-29 16:40:05 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-29 16:40:05 +0000
commit684426bcf54acc39f39782d40b52027eeef33c43 (patch)
treee0a68f1abdf30fb73d3b72855483d4b033904fcd /dev-python
parentUse python_mod_compile instead of python_mod_optimize. (diff)
downloadgentoo-2-684426bcf54acc39f39782d40b52027eeef33c43.tar.gz
gentoo-2-684426bcf54acc39f39782d40b52027eeef33c43.tar.bz2
gentoo-2-684426bcf54acc39f39782d40b52027eeef33c43.zip
Fix python_mod_optimize usage.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild6
-rw-r--r--dev-python/wxpython/wxpython-2.8.7.1.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 506c49bb93ee..dce125974488 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.87 2008/03/21 01:56:37 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.88 2008/05/29 16:40:05 hawking Exp $
+
+ 29 May 2008; Ali Polatel <hawking@gentoo.org> wxpython-2.6.4.0-r1.ebuild,
+ wxpython-2.8.7.1.ebuild:
+ Fix python_mod_optimize usage.
21 Mar 2008; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.4.0-r1.ebuild,
wxpython-2.8.7.1.ebuild:
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
index ded082f890a5..e69b59a0b61e 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.13 2008/03/21 01:56:37 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.14 2008/05/29 16:40:05 hawking Exp $
EAPI=1
@@ -102,10 +102,10 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize
-
local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+ python_mod_optimize ${size_pkgs}
+
alternatives_auto_makesym \
"${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
alternatives_auto_makesym \
diff --git a/dev-python/wxpython/wxpython-2.8.7.1.ebuild b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
index 2f9946fe57f2..27c69aeaa1d6 100644
--- a/dev-python/wxpython/wxpython-2.8.7.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.10 2008/03/21 01:56:37 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.11 2008/05/29 16:40:05 hawking Exp $
EAPI="1"
WX_GTK_VER="2.8"
@@ -91,10 +91,10 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize
-
local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+ python_mod_optimize ${site_pkgs}
+
alternatives_auto_makesym \
"${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
alternatives_auto_makesym \