summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-01-07 00:04:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-01-07 00:04:21 +0000
commit7595bc8ef9e6d070e3167f734922acb36163e3e4 (patch)
tree2cc4c7e683a66e6e42b407a2f369c30323000e65 /dev-python
parentTest for libpcre built with USE=unicode. Bug #203838 (diff)
downloadgentoo-2-7595bc8ef9e6d070e3167f734922acb36163e3e4.tar.gz
gentoo-2-7595bc8ef9e6d070e3167f734922acb36163e3e4.tar.bz2
gentoo-2-7595bc8ef9e6d070e3167f734922acb36163e3e4.zip
bump to 2.12.1
* removing parallel build limitation * reactivate tests * use emake in src_install (Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygtk/ChangeLog12
-rw-r--r--dev-python/pygtk/files/digest-pygtk-2.12.16
-rw-r--r--dev-python/pygtk/pygtk-2.12.1.ebuild88
3 files changed, 104 insertions, 2 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 8a7ecf8e49b2..fa0d2afe4b5f 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pygtk
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.174 2007/12/22 16:34:49 dang Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.175 2008/01/07 00:04:20 eva Exp $
+
+*pygtk-2.12.1 (06 Jan 2008)
+
+ 06 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org> +pygtk-2.12.1.ebuild:
+ bump to 2.12.1
+ * removing parallel build limitation
+ * reactivate tests
+ * use emake in src_install
*pygtk-2.12.0-r1 (22 Dec 2007)
diff --git a/dev-python/pygtk/files/digest-pygtk-2.12.1 b/dev-python/pygtk/files/digest-pygtk-2.12.1
new file mode 100644
index 000000000000..94928e6433a7
--- /dev/null
+++ b/dev-python/pygtk/files/digest-pygtk-2.12.1
@@ -0,0 +1,6 @@
+MD5 a816346d750d61e3fa67a200e4292694 pygtk-2.12.1.tar.bz2 2175955
+RMD160 c368deab52524248593b77984e93f18150efa0f4 pygtk-2.12.1.tar.bz2 2175955
+SHA256 4100ed4bf295b03106308f1cfb9931cc22910401dab785f8bd3af9935f1fe13d pygtk-2.12.1.tar.bz2 2175955
+MD5 ad0624dd26a19fbb9286c1c7711a60bc pygtk2reference-2.9.0.tar.bz2 759824
+RMD160 966cae10fa93b512f565aa0d552a8c83fe5de53f pygtk2reference-2.9.0.tar.bz2 759824
+SHA256 a01cf19a26aca49b2522f6c987cb48bcc9a2a393b4383709707acd5a994e00fd pygtk2reference-2.9.0.tar.bz2 759824
diff --git a/dev-python/pygtk/pygtk-2.12.1.ebuild b/dev-python/pygtk/pygtk-2.12.1.ebuild
new file mode 100644
index 000000000000..79b6d97775d3
--- /dev/null
+++ b/dev-python/pygtk/pygtk-2.12.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.12.1.ebuild,v 1.1 2008/01/07 00:04:20 eva Exp $
+
+inherit gnome.org python flag-o-matic eutils virtualx
+
+DESCRIPTION="GTK+2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+DOC_FILE="pygtk2reference-2.9.0.tar.bz2"
+SRC_URI="${SRC_URI}
+ doc? ( mirror://gnome/sources/pygtk2reference/2.9/${DOC_FILE} )"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples opengl"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/pango-1.16.0
+ >=dev-libs/atk-1.12.0
+ >=x11-libs/gtk+-2.11.6
+ >=gnome-base/libglade-2.5.0
+ >=dev-lang/python-2.4.4-r5
+ >=dev-python/pycairo-1.0.2
+ >=dev-python/pygobject-2.14
+ !arm? ( dev-python/numeric )
+ opengl? ( virtual/opengl
+ dev-python/pyopengl
+ >=x11-libs/gtkglarea-1.99
+ )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ use doc || sed -e 's/\(SUBDIRS =.*\) docs$/\1/' -i "${S}"/Makefile.am
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_compile() {
+ use hppa && append-flags -ffunction-sections
+ econf $(use_enable doc docs) --enable-thread || die
+ # possible problems with parallel builds (#45776)
+ #emake -j1 || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+
+ if use examples; then
+ rm examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ if use doc; then
+ insinto /usr/share/gtk-doc/html/pygtk
+ cd "${WORKDIR}"/pygtk2reference
+ doins -r cursors icons images
+ fi
+}
+
+src_test() {
+ cd tests
+ Xemake check-local || die "tests failed"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/share/pygtk/2.0/codegen /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/share/pygtk/2.0/codegen
+ python_mod_cleanup
+ rm -f "${ROOT}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+}