summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-07-08 04:10:15 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-07-08 04:10:15 +0000
commit7b4e626c8b73d07de5d911446a86c3f06f7efb81 (patch)
treea3e96d512691244f9da59f0f2bc96c182f5d6bf0 /dev-python
parent(#230981) Add sys-fs/e2fsprogs to RDEPEND for libuuid. (diff)
downloadgentoo-2-7b4e626c8b73d07de5d911446a86c3f06f7efb81.tar.gz
gentoo-2-7b4e626c8b73d07de5d911446a86c3f06f7efb81.tar.bz2
gentoo-2-7b4e626c8b73d07de5d911446a86c3f06f7efb81.zip
Initial import
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-tuxonice-r1 i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mpmath/ChangeLog10
-rw-r--r--dev-python/mpmath/Manifest4
-rw-r--r--dev-python/mpmath/metadata.xml10
-rw-r--r--dev-python/mpmath/mpmath-0.8.ebuild40
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
new file mode 100644
index 000000000000..d073d99dc7c5
--- /dev/null
+++ b/dev-python/mpmath/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/mpmath
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.1 2008/07/08 04:10:15 grozin Exp $
+
+*mpmath-0.8 (08 Jul 2008)
+
+ 08 Jul 2008; Andrey Grozin <grozin@gentoo.org> +metadata.xml,
+ +mpmath-0.8.ebuild:
+ Initial import
+
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
new file mode 100644
index 000000000000..4acc81fd5399
--- /dev/null
+++ b/dev-python/mpmath/Manifest
@@ -0,0 +1,4 @@
+DIST mpmath-0.8.tar.gz 111825 RMD160 cf090d139643d7c10c13a2e12a558f1c44bbe2d2 SHA1 bdb5f2b9efc2ea730b004de3bf2593c74ffbdd34 SHA256 ff25bfa44e96ffe25a69c9de4577f810d953b2936bc57df3009ec5d86474eb67
+EBUILD mpmath-0.8.ebuild 753 RMD160 82cc0ddcd068ec165f7002f33c07cacc2d9fd5dd SHA1 c4e5521afcc5e8cefa17df3c0a8afb463b665eb8 SHA256 65f352d1fd95de04dd7567cb993deffe538a2dd8321b198053d0a688f4e65116
+MISC ChangeLog 249 RMD160 528723877c0a5c7ebebfcfb7ef35d4b9b2b52f07 SHA1 df16e6766bd0033f1a0c16bf3c37fbe9ea5bb98f SHA256 f22571852754ef5df573e9f3a1dcbd1716a79ad3321a2b0fbd924485ef4916c3
+MISC metadata.xml 365 RMD160 ece7c524ccedeb12b39753fba601dd830c25f8ab SHA1 afc79096300fa102014e4e794fdc20814b25f363 SHA256 d6bb09b59c81f6643741decbdce8d164005673b406d703ce5c2448891b2db2a8
diff --git a/dev-python/mpmath/metadata.xml b/dev-python/mpmath/metadata.xml
new file mode 100644
index 000000000000..180d1643d44c
--- /dev/null
+++ b/dev-python/mpmath/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>A Python library for arbitrary-precision floating-point arithmetic</longdescription>
+</pkgmetadata>
diff --git a/dev-python/mpmath/mpmath-0.8.ebuild b/dev-python/mpmath/mpmath-0.8.ebuild
new file mode 100644
index 000000000000..3d18e2380526
--- /dev/null
+++ b/dev-python/mpmath/mpmath-0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.8.ebuild,v 1.1 2008/07/08 04:10:15 grozin Exp $
+
+NEED_PYTHON=2.4
+inherit distutils
+
+DESCRIPTION="A python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="http://code.google.com/p/mpmath/"
+SRC_URI="http://mpmath.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc examples test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-python/py )"
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+
+ if use doc; then
+ cd doc
+ "${python}" build.py
+ dohtml -r build/*
+ cd ..
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/*
+ fi
+}
+
+src_test() {
+ cd mpmath/tests
+ py.test || die "tests failed"
+}