summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-07-02 03:54:28 +0000
committerJon Nelson <jnelson@gentoo.org>2002-07-02 03:54:28 +0000
commit7b72c9a3eaf1be98e180556623a1053a9e992338 (patch)
treec98719190bbdfeda799ffade0a8298d84610edf5 /dev-python
parentfix minor packaging oops (diff)
downloadgentoo-2-7b72c9a3eaf1be98e180556623a1053a9e992338.tar.gz
gentoo-2-7b72c9a3eaf1be98e180556623a1053a9e992338.tar.bz2
gentoo-2-7b72c9a3eaf1be98e180556623a1053a9e992338.zip
update python-docs to 2.2.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-docs/ChangeLog8
-rw-r--r--dev-python/python-docs/files/digest-python-docs-2.2.11
-rw-r--r--dev-python/python-docs/python-docs-2.2.1.ebuild23
3 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index f740582e7c4b..6de1474a73b3 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for dev-python/python-docs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.2 2002/04/07 01:54:24 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.3 2002/07/02 03:54:28 jnelson Exp $
+*python-docs-2.2.1 (1 Jul 2002)
+
+ 1 Jul 2002; Jon Nelson <jnelson@gentoo.org> python-docs-2.2.1.ebuild
+
+ Added ebuild for 2.2.1 docs
+
*python-docs-2.2 (6 Apr 2002)
6 Apr 2002; Jon Nelson <jnelson@gentoo.org> ChangeLog, python-docs-2.2.ebuild
diff --git a/dev-python/python-docs/files/digest-python-docs-2.2.1 b/dev-python/python-docs/files/digest-python-docs-2.2.1
new file mode 100644
index 000000000000..1a027d8de1c1
--- /dev/null
+++ b/dev-python/python-docs/files/digest-python-docs-2.2.1
@@ -0,0 +1 @@
+MD5 4c04d71113914c7e4619ff7dc732dbbd html-2.2.1.tar.bz2 944676
diff --git a/dev-python/python-docs/python-docs-2.2.1.ebuild b/dev-python/python-docs/python-docs-2.2.1.ebuild
new file mode 100644
index 000000000000..03f65750b26c
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.2.1.ebuild,v 1.1 2002/07/02 03:54:28 jnelson Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTML documentation for Python"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2"
+HOMEPAGE="http://www.python.org/doc/2.2/"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+
+src_install() {
+ docinto html
+ cp -R ${S}/* ${D}/usr/share/doc/${P}/html
+ chown -R root.root ${D}/usr/share/doc/${P}/html
+ find ${D}/usr/share/doc/${P}/html -type d -exec chmod 0755 \{\} \;
+ find ${D}/usr/share/doc/${P}/html -type f -exec chmod 0644 \{\} \;
+}