summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-02-13 01:36:18 +0000
committerJeroen Roovers <jer@gentoo.org>2014-02-13 01:36:18 +0000
commit862001a04d2bd95c1f4c7590132eae817836ff34 (patch)
tree721eb32632bcbfc551d602bfa29c817e195ecd4a /dev-python
parentInstall jail.conf(5) (bug #501116 by Balint SZENTE). (diff)
downloadgentoo-2-862001a04d2bd95c1f4c7590132eae817836ff34.tar.gz
gentoo-2-862001a04d2bd95c1f4c7590132eae817836ff34.tar.bz2
gentoo-2-862001a04d2bd95c1f4c7590132eae817836ff34.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/unidecode/ChangeLog8
-rw-r--r--dev-python/unidecode/metadata.xml20
-rw-r--r--dev-python/unidecode/unidecode-0.04.14.ebuild (renamed from dev-python/unidecode/unidecode-0.04.9.ebuild)21
3 files changed, 24 insertions, 25 deletions
diff --git a/dev-python/unidecode/ChangeLog b/dev-python/unidecode/ChangeLog
index 10dbabfe6e50..e0ae5fe0e635 100644
--- a/dev-python/unidecode/ChangeLog
+++ b/dev-python/unidecode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/unidecode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unidecode/ChangeLog,v 1.9 2014/01/16 17:20:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unidecode/ChangeLog,v 1.10 2014/02/13 01:36:18 jer Exp $
+
+*unidecode-0.04.14 (13 Feb 2014)
+
+ 13 Feb 2014; Jeroen Roovers <jer@gentoo.org> -unidecode-0.04.9.ebuild,
+ +unidecode-0.04.14.ebuild, metadata.xml:
+ Version bump.
16 Jan 2014; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Spelling.
diff --git a/dev-python/unidecode/metadata.xml b/dev-python/unidecode/metadata.xml
index 2785048d73fe..e92c7fd76214 100644
--- a/dev-python/unidecode/metadata.xml
+++ b/dev-python/unidecode/metadata.xml
@@ -1,18 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- </maintainer>
- <longdescription lang="en">
-This is a Python port of Text::Unidecode Perl module
-
-It often happens that you have text data in Unicode, but you need to represent it in ASCII. For example when integrating with legacy code that doesn't support Unicode, or for ease of entry of non-Roman names on a US keyboard, or when constructing ASCII machine identifiers from human-readable Unicode strings that should still be somewhat intelligible (a popular example of this is when making a URL slug from an article title).
-
-In most of these examples you could represent Unicode characters as "???" or "\15BA\15A0\1610", to mention two extreme cases. But that's nearly useless to someone who actually wants to read what the text says.
-
-What Unidecode provides is a middle road: function unidecode() takes Unicode data and tries to represent it in ASCII characters (i.e., the universally displayable characters between 0x00 and 0x7F), where the compromises taken when mapping between two character sets are chosen to be near what a human with a US keyboard would choose.
-
-Note that this module generally produces better results than simply stripping accents from characters (which can be done in Python with built-in functions). It is based on hand-tuned character mappings that for example also contain ASCII approximations for symbols and non-Latin alphabets.
- </longdescription>
+<maintainer>
+<email>jer@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+This is a Python port of the Text::Unidecode Perl (<pkg>dev-perl/Text-Unidecode</pkg> module
+</longdescription>
</pkgmetadata>
diff --git a/dev-python/unidecode/unidecode-0.04.9.ebuild b/dev-python/unidecode/unidecode-0.04.14.ebuild
index 5481125f1d3b..3d5f5e9c8dd6 100644
--- a/dev-python/unidecode/unidecode-0.04.9.ebuild
+++ b/dev-python/unidecode/unidecode-0.04.14.ebuild
@@ -1,18 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unidecode/unidecode-0.04.9.ebuild,v 1.4 2012/05/30 12:53:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unidecode/unidecode-0.04.14.ebuild,v 1.1 2014/02/13 01:36:18 jer Exp $
-EAPI=4
-
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5"
-DISTUTILS_SRC_TEST=setup.py
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
MY_PN=Unidecode
MY_P=${MY_PN}-${PV}
-inherit distutils
+inherit distutils-r1
DESCRIPTION="Module providing ASCII transliterations of Unicode text"
HOMEPAGE="http://pypi.python.org/pypi/Unidecode"
@@ -21,6 +17,11 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}