summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-08-24 07:15:24 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-08-24 07:15:24 +0000
commit9683fa8071257552de2d6a0f2fdfc44e2b276554 (patch)
tree73906e4ffdc98bfb4cab0a5a9bbcf895d9be1476 /dev-python
parentCommon functionality required for splitting various GNOME python bindings (diff)
downloadgentoo-2-9683fa8071257552de2d6a0f2fdfc44e2b276554.tar.gz
gentoo-2-9683fa8071257552de2d6a0f2fdfc44e2b276554.tar.bz2
gentoo-2-9683fa8071257552de2d6a0f2fdfc44e2b276554.zip
Initial import of gnome-python split ebuilds. This package installs a common pkgconfig file.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python-base/ChangeLog11
-rw-r--r--dev-python/gnome-python-base/Manifest4
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.22.1.ebuild34
-rw-r--r--dev-python/gnome-python-base/metadata.xml6
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/gnome-python-base/ChangeLog b/dev-python/gnome-python-base/ChangeLog
new file mode 100644
index 000000000000..f4e010d3a415
--- /dev/null
+++ b/dev-python/gnome-python-base/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/gnome-python-base
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.1 2008/08/24 07:15:24 ford_prefect Exp $
+
+*gnome-python-base-2.22.1 (20 Aug 2008)
+
+ 20 Aug 2008; Arun Raghavan <ford_prefect@gentoo.org> +metadata.xml,
+ +gnome-python-base-2.22.1.ebuild:
+ Initial import of gnome-python split ebuilds. This package installs a
+ common pkgconfig file.
+
diff --git a/dev-python/gnome-python-base/Manifest b/dev-python/gnome-python-base/Manifest
new file mode 100644
index 000000000000..7358990ffc3d
--- /dev/null
+++ b/dev-python/gnome-python-base/Manifest
@@ -0,0 +1,4 @@
+DIST gnome-python-2.22.1.tar.bz2 552363 RMD160 f2e4033cf74822c939cb14cdb69f9583e07fbf25 SHA1 91402febafd40d59c0eb3f9da80a3406e4e7a76e SHA256 559b5d857b4fbc31418bc677f3391182ba1c357cabb8dfee04a1e709a7a63d01
+EBUILD gnome-python-base-2.22.1.ebuild 887 RMD160 e9a9c0a614f343461a9d248a82bae6769cdfcf44 SHA1 debd1cbab58784ce806924114351f7d9654b294f SHA256 1971c8d2915c3d903adb2281d392b1474c6fb0bc040d39e5ec61a2f265f8aab6
+MISC ChangeLog 374 RMD160 136812758b551e01f889707000769b9e92a963e8 SHA1 424c6d9b22134d60f7d03a5fe12942adce2d022d SHA256 f6b40927628ce9b88724bf1f8e3043b5f6e65802dbf1f6614450a7e2c3af2eba
+MISC metadata.xml 178 RMD160 ec0937689a645defb2b870b481c4d4db57a0fa73 SHA1 aa77d904544ca6e6e684658ec652463fdb2ca58d SHA256 ccdf4a821074a281d4fd442460b65f57e77546cea36756c435db5529d22fa2a6
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.22.1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.22.1.ebuild
new file mode 100644
index 000000000000..f2166002f16d
--- /dev/null
+++ b/dev-python/gnome-python-base/gnome-python-base-2.22.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/gnome-python-base-2.22.1.ebuild,v 1.1 2008/08/24 07:15:24 ford_prefect Exp $
+
+inherit versionator eutils gnome2
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=dev-python/pygtk-2.10.3
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+}
diff --git a/dev-python/gnome-python-base/metadata.xml b/dev-python/gnome-python-base/metadata.xml
new file mode 100644
index 000000000000..888e60bf6a90
--- /dev/null
+++ b/dev-python/gnome-python-base/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<herd>gnome</herd>
+</pkgmetadata>