summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-21 18:22:40 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-21 18:22:40 +0000
commit9d3d440e7863a470feb0729332171f44f3bfff17 (patch)
tree9c9f279a45380cf47ab0f1012245bd2dc40c4043 /dev-python
parentalso scan for older AC_PROG_INTLTOOL since not all packages have updated yet (diff)
downloadgentoo-2-9d3d440e7863a470feb0729332171f44f3bfff17.tar.gz
gentoo-2-9d3d440e7863a470feb0729332171f44f3bfff17.tar.bz2
gentoo-2-9d3d440e7863a470feb0729332171f44f3bfff17.zip
Version bump #416811 by Johan Bergström.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.4.1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 8b1482a83363..8aa019df0fb3 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.45 2012/05/21 18:11:15 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.46 2012/05/21 18:22:40 vapier Exp $
+
+*boto-2.4.1 (21 May 2012)
+
+ 21 May 2012; Mike Frysinger <vapier@gentoo.org> +boto-2.4.1.ebuild:
+ Version bump #416811 by Johan Bergström.
21 May 2012; Jeff Horelick <jdhore@gentoo.org> boto-2.3.0.ebuild:
marked x86 per bug 416861
diff --git a/dev-python/boto/boto-2.4.1.ebuild b/dev-python/boto/boto-2.4.1.ebuild
new file mode 100644
index 000000000000..b9f74cf5a51e
--- /dev/null
+++ b/dev-python/boto/boto-2.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.4.1.ebuild,v 1.1 2012/05/21 18:22:40 vapier Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://github/boto/boto/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools
+ test? ( dev-python/m2crypto )"
+RDEPEND="dev-python/m2crypto"
+
+# Requires Amazon Web Services keys to pass some tests
+RESTRICT="test"