summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 19:45:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 19:45:35 +0000
commit9edf95c3f213204b2e4c7bda4ec06e126c74819b (patch)
treec2bcd86f2922232826a0f9690e26c68ee9376c1d /dev-python
parentReplace rtmpdump with rtmp useflag. As is done in ffmpeg and xbmc. (diff)
downloadgentoo-2-9edf95c3f213204b2e4c7bda4ec06e126c74819b.tar.gz
gentoo-2-9edf95c3f213204b2e4c7bda4ec06e126c74819b.tar.bz2
gentoo-2-9edf95c3f213204b2e4c7bda4ec06e126c74819b.zip
Update EAPI. Fix dependencies. Don't inherit distutils.eclass and python.eclass twice. Use PyPI mirrors. Set PYTHON_MODNAME. Set TWISTED_PLUGINS and avoid custom regeneration of Twisted plugin cache (bug #329313).
(Portage version: 2.2_rc91_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/axiom/ChangeLog9
-rw-r--r--dev-python/axiom/axiom-0.6.0.ebuild38
2 files changed, 20 insertions, 27 deletions
diff --git a/dev-python/axiom/ChangeLog b/dev-python/axiom/ChangeLog
index 7c22507c555b..d05f65be4911 100644
--- a/dev-python/axiom/ChangeLog
+++ b/dev-python/axiom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/axiom
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/ChangeLog,v 1.30 2010/08/12 09:08:05 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/ChangeLog,v 1.31 2010/10/10 19:45:35 arfrever Exp $
+
+ 10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ axiom-0.6.0.ebuild:
+ Update EAPI. Fix dependencies. Don't inherit distutils.eclass and
+ python.eclass twice. Use PyPI mirrors. Set PYTHON_MODNAME. Set
+ TWISTED_PLUGINS and avoid custom regeneration of Twisted plugin cache
+ (bug #329313).
12 Aug 2010; Markus Meier <maekke@gentoo.org> axiom-0.6.0.ebuild:
amd64/x86 stable, bug #330773
diff --git a/dev-python/axiom/axiom-0.6.0.ebuild b/dev-python/axiom/axiom-0.6.0.ebuild
index 19bb20c038bd..c93d70f02561 100644
--- a/dev-python/axiom/axiom-0.6.0.ebuild
+++ b/dev-python/axiom/axiom-0.6.0.ebuild
@@ -1,40 +1,41 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/axiom-0.6.0.ebuild,v 1.3 2010/08/12 09:08:05 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/axiom-0.6.0.ebuild,v 1.4 2010/10/10 19:45:35 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
# setup.py uses epsilon.setuphelper.autosetup(), which tries to use
# build-${PYTHON_ABI} directories as packages.
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-inherit distutils eutils twisted
+inherit eutils twisted
MY_PN="Axiom"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Axiom is an object database implemented on top of SQLite."
HOMEPAGE="http://divmod.org/trac/wiki/DivmodAxiom http://pypi.python.org/pypi/Axiom"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~ia64 ~ppc64 x86"
IUSE=""
-DEPEND="|| ( >=dev-lang/python-2.5[sqlite]
- ( >=dev-lang/python-2.4 >=dev-python/pysqlite-2.0 ) )
- >=dev-db/sqlite-3.2.1
+DEPEND="|| ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 )
+ >=dev-python/epsilon-0.6
>=dev-python/twisted-2.4
- >=dev-python/twisted-conch-0.7.0-r1
- >=dev-python/epsilon-0.6"
+ >=dev-python/twisted-conch-0.7.0-r1"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
DOCS="NAME.txt"
+PYTHON_MODNAME="axiom twisted/plugins/axiom_plugins.py"
+TWISTED_PLUGINS="axiom.plugins twisted.plugins"
src_prepare() {
epatch "${FILESDIR}/${PN}-0.5.30-sqlite3.patch"
@@ -57,18 +58,3 @@ src_test() {
src_install() {
PORTAGE_PLUGINCACHE_NOOP="1" distutils_src_install
}
-
-update_axiom_plugin_cache() {
- einfo "Updating axiom plugin cache..."
- "$(PYTHON)" -c 'from twisted.plugin import IPlugin, getPlugins;from axiom import plugins; list(getPlugins(IPlugin, plugins))'
-}
-
-pkg_postrm() {
- twisted_pkg_postrm
- python_execute_function update_axiom_plugin_cache
-}
-
-pkg_postinst() {
- twisted_pkg_postinst
- python_execute_function update_axiom_plugin_cache
-}