summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 23:46:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 23:46:43 +0000
commitc711f7cbfe112796303b4cc1c31f3ff53d880c33 (patch)
tree0decf0e23b140bfb94cb3a55266b7ad3a74c6966 /dev-python
parentFix dependencies. (diff)
downloadgentoo-2-c711f7cbfe112796303b4cc1c31f3ff53d880c33.tar.gz
gentoo-2-c711f7cbfe112796303b4cc1c31f3ff53d880c33.tar.bz2
gentoo-2-c711f7cbfe112796303b4cc1c31f3ff53d880c33.zip
Update EAPI. Fix dependencies. Call python_pkg_setup().
(Portage version: 2.2.0_alpha2_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/soappy/ChangeLog6
-rw-r--r--dev-python/soappy/soappy-0.12.0.ebuild13
2 files changed, 13 insertions, 6 deletions
diff --git a/dev-python/soappy/ChangeLog b/dev-python/soappy/ChangeLog
index 31dc51573729..500f9bb57957 100644
--- a/dev-python/soappy/ChangeLog
+++ b/dev-python/soappy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/soappy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/soappy/ChangeLog,v 1.33 2010/02/07 21:06:59 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/soappy/ChangeLog,v 1.34 2010/10/30 23:46:43 arfrever Exp $
+
+ 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ soappy-0.12.0.ebuild:
+ Update EAPI. Fix dependencies. Call python_pkg_setup().
07 Feb 2010; Peter Volkov <pva@gentoo.org> soappy-0.12.0.ebuild:
Add inherit eutils: epatch is defined there.
diff --git a/dev-python/soappy/soappy-0.12.0.ebuild b/dev-python/soappy/soappy-0.12.0.ebuild
index 1689fc49615f..3f51d2694ee3 100644
--- a/dev-python/soappy/soappy-0.12.0.ebuild
+++ b/dev-python/soappy/soappy-0.12.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/soappy/soappy-0.12.0.ebuild,v 1.18 2010/02/07 21:06:59 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/soappy/soappy-0.12.0.ebuild,v 1.19 2010/10/30 23:46:43 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit eutils distutils
@@ -23,15 +25,16 @@ DEPEND=">=dev-python/fpconst-0.7.1
dev-python/pyxml"
RDEPEND="${DEPEND}
ssl? ( dev-python/m2crypto )"
-RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME="${MY_PN}"
DOCS="RELEASE_INFO"
+PYTHON_MODNAME="${MY_PN}"
pkg_setup() {
- if use ssl && ! has_version dev-lang/python[ssl]; then
+ python_pkg_setup
+
+ if use ssl && ! has_version "=dev-lang/python-2*[ssl]"; then
ewarn "The 'ssl' USE-flag is enabled, but dev-lang/python is"
ewarn "not compiled with it. You'll only get server-side SSL support."
ewarn "Just emerge dev-lang/python afterwards with the ssl USE-flag to"