summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-08-12 07:52:49 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-08-12 07:52:49 +0000
commitda3e4ead9d864dbbaa25f1ba02ed252713835be5 (patch)
tree81ca088d45091a85a76165a808fa265179f3fbf7 /dev-python
parentRemove old version. (diff)
downloadgentoo-2-da3e4ead9d864dbbaa25f1ba02ed252713835be5.tar.gz
gentoo-2-da3e4ead9d864dbbaa25f1ba02ed252713835be5.tar.bz2
gentoo-2-da3e4ead9d864dbbaa25f1ba02ed252713835be5.zip
Version bump dulwich to 0.8.0.
(Portage version: 2.1.10.4/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/ChangeLog7
-rw-r--r--dev-python/dulwich/dulwich-0.8.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 4409b6c6bb62..9ed90d51fe7a 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.31 2011/06/06 08:31:12 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.32 2011/08/12 07:52:49 djc Exp $
+
+*dulwich-0.8.0 (12 Aug 2011)
+
+ 12 Aug 2011; Dirkjan Ochtman <djc@gentoo.org> +dulwich-0.8.0.ebuild:
+ Version bump to 0.8.0.
06 Jun 2011; Dirkjan Ochtman <djc@gentoo.org> -dulwich-0.7.0.ebuild:
Remove old version.
diff --git a/dev-python/dulwich/dulwich-0.8.0.ebuild b/dev-python/dulwich/dulwich-0.8.0.ebuild
new file mode 100644
index 000000000000..6174bddc5a11
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.8.0.ebuild,v 1.1 2011/08/12 07:52:49 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ test? ( || ( dev-lang/python:2.7 dev-python/unittest2 dev-python/testtools ) )"
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s/test_fetch_from_dulwich(/_&/" -i dulwich/tests/compat/server_utils.py
+}
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _diff_tree _objects _pack; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/dulwich/${module}.so" "dulwich/${module}.so" || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}