summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-16 08:04:44 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-16 08:04:44 +0000
commite464fe9df0e18a9cb1eb66a59c10a088b8138647 (patch)
treecadf6f22e41fd3d13baaae114a7b33c10eb443df /dev-python
parentBump (diff)
downloadgentoo-2-e464fe9df0e18a9cb1eb66a59c10a088b8138647.tar.gz
gentoo-2-e464fe9df0e18a9cb1eb66a59c10a088b8138647.tar.bz2
gentoo-2-e464fe9df0e18a9cb1eb66a59c10a088b8138647.zip
drop old, migration -> distutils-r1
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/graphcanvas/ChangeLog8
-rw-r--r--dev-python/graphcanvas/graphcanvas-3.0.0.ebuild42
-rw-r--r--dev-python/graphcanvas/graphcanvas-4.0.0.ebuild43
-rw-r--r--dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild31
4 files changed, 38 insertions, 86 deletions
diff --git a/dev-python/graphcanvas/ChangeLog b/dev-python/graphcanvas/ChangeLog
index 9333f7538bcf..ec6d7b79b4cc 100644
--- a/dev-python/graphcanvas/ChangeLog
+++ b/dev-python/graphcanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/graphcanvas
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graphcanvas/ChangeLog,v 1.6 2013/04/08 07:17:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graphcanvas/ChangeLog,v 1.7 2013/04/16 08:04:44 idella4 Exp $
+
+*graphcanvas-4.0.2-r1 (16 Apr 2013)
+
+ 16 Apr 2013; Ian Delaney <idella4@gentoo.org> +graphcanvas-4.0.2-r1.ebuild,
+ -graphcanvas-3.0.0.ebuild, -graphcanvas-4.0.0.ebuild:
+ drop old, migration -> distutils-r1
*graphcanvas-4.0.2 (08 Apr 2013)
diff --git a/dev-python/graphcanvas/graphcanvas-3.0.0.ebuild b/dev-python/graphcanvas/graphcanvas-3.0.0.ebuild
deleted file mode 100644
index cc12d4493fdf..000000000000
--- a/dev-python/graphcanvas/graphcanvas-3.0.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graphcanvas/graphcanvas-3.0.0.ebuild,v 1.1 2011/02/01 02:48:40 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-MY_PN="GraphCanvas"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Enthought Tool Suite: Interactive Graph (network) Visualization"
-HOMEPAGE="http://pypi.python.org/pypi/GraphCanvas"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND=">=dev-python/enable-3.4.0
- dev-python/networkx
- dev-python/numpy
- >=dev-python/traits-3.6.0"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="enthought"
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/graphcanvas/graphcanvas-4.0.0.ebuild b/dev-python/graphcanvas/graphcanvas-4.0.0.ebuild
deleted file mode 100644
index 07e9ae0812a7..000000000000
--- a/dev-python/graphcanvas/graphcanvas-4.0.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graphcanvas/graphcanvas-4.0.0.ebuild,v 1.4 2012/12/06 17:34:48 bicatali Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.* *-jython"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Interactive Graph (network) Visualization"
-HOMEPAGE="http://pypi.python.org/pypi/graphcanvas"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-RDEPEND="dev-python/networkx
- dev-python/enable"
-DEPEND="dev-python/setuptools
- test? (
- ${RDEPEND}
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
-
-src_test() {
- VIRTUALX_COMMAND="distutils_src_test" virtualmake
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild b/dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..ee12f001aa6c
--- /dev/null
+++ b/dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graphcanvas/graphcanvas-4.0.2-r1.ebuild,v 1.1 2013/04/16 08:04:44 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: Interactive Graph (network) Visualization"
+HOMEPAGE="http://pypi.python.org/pypi/graphcanvas"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="dev-python/networkx
+ >=dev-python/enable-4[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples/
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}