summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatteo Azzali <mattepiu@gentoo.org>2006-11-01 09:53:31 +0000
committerMatteo Azzali <mattepiu@gentoo.org>2006-11-01 09:53:31 +0000
commited1be12b6a487beb257763c37cd1e8e3d648ab78 (patch)
tree56b4050f5cf92276f844ae45f283dc265e362c69 /dev-python
parentVersion bump (bug 150735), and removed old version. (diff)
downloadgentoo-2-ed1be12b6a487beb257763c37cd1e8e3d648ab78.tar.gz
gentoo-2-ed1be12b6a487beb257763c37cd1e8e3d648ab78.tar.bz2
gentoo-2-ed1be12b6a487beb257763c37cd1e8e3d648ab78.zip
version bump to 0.4.10.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mmpython/ChangeLog9
-rw-r--r--dev-python/mmpython/files/digest-mmpython-0.4.103
-rw-r--r--dev-python/mmpython/files/mmpython-0.4.10-missing_stdint_headers.patch20
-rw-r--r--dev-python/mmpython/mmpython-0.4.10.ebuild23
4 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/mmpython/ChangeLog b/dev-python/mmpython/ChangeLog
index dc441902f7e7..0b9664b2bdbd 100644
--- a/dev-python/mmpython/ChangeLog
+++ b/dev-python/mmpython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/mmpython
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/ChangeLog,v 1.25 2006/07/28 10:19:16 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/ChangeLog,v 1.26 2006/11/01 09:53:31 mattepiu Exp $
+
+*mmpython-0.4.10 (01 Nov 2006)
+
+ 01 Nov 2006; Matteo Azzali <mattepiu@gentoo.org>
+ +files/mmpython-0.4.10-missing_stdint_headers.patch,
+ +mmpython-0.4.10.ebuild:
+ version bump.
28 Jul 2006; Alastair Tse <liquidx@gentoo.org>
+files/mmpython-0.4.9-missing_stdint_headers.patch, mmpython-0.4.9.ebuild:
diff --git a/dev-python/mmpython/files/digest-mmpython-0.4.10 b/dev-python/mmpython/files/digest-mmpython-0.4.10
new file mode 100644
index 000000000000..a7e246680d86
--- /dev/null
+++ b/dev-python/mmpython/files/digest-mmpython-0.4.10
@@ -0,0 +1,3 @@
+MD5 3a1f2e754308ac8cacd266c1350dcf34 mmpython-0.4.10.tar.gz 128200
+RMD160 8610c62e7de4b498c5d776eb73d8cd3bd19605c9 mmpython-0.4.10.tar.gz 128200
+SHA256 1e46ef16c19aac6b0e3c335d6e3eed304874605a41b277869cea413d9a72f8ac mmpython-0.4.10.tar.gz 128200
diff --git a/dev-python/mmpython/files/mmpython-0.4.10-missing_stdint_headers.patch b/dev-python/mmpython/files/mmpython-0.4.10-missing_stdint_headers.patch
new file mode 100644
index 000000000000..67522169212c
--- /dev/null
+++ b/dev-python/mmpython/files/mmpython-0.4.10-missing_stdint_headers.patch
@@ -0,0 +1,20 @@
+--- disc/ifomodule.c~ 2004-07-17 10:46:52.000000000 +0200
++++ disc/ifomodule.c 2006-04-11 07:59:38.030697690 +0200
+@@ -9,6 +9,7 @@
+ #include <unistd.h>
+ #include <assert.h>
+ #include <inttypes.h>
++#include <stdint.h>
+
+ #include <dvdread/dvd_reader.h>
+ #include <dvdread/ifo_types.h>
+--- disc/cdrommodule.c~ 2003-06-23 21:26:16.000000000 +0200
++++ disc/cdrommodule.c 2006-04-11 07:58:02.463087444 +0200
+@@ -36,6 +36,7 @@
+ #include "Python.h"
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
++#include <stdint.h>
+
+ #ifdef __linux__
+ #include <linux/cdrom.h>
diff --git a/dev-python/mmpython/mmpython-0.4.10.ebuild b/dev-python/mmpython/mmpython-0.4.10.ebuild
new file mode 100644
index 000000000000..066a758d96eb
--- /dev/null
+++ b/dev-python/mmpython/mmpython-0.4.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mmpython/mmpython-0.4.10.ebuild,v 1.1 2006/11/01 09:53:31 mattepiu Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Media metadata retrieval framework for Python."
+HOMEPAGE="http://sourceforge.net/projects/mmpython/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="dvd"
+
+DEPEND="${DEPEND}
+ dvd? ( >=media-libs/libdvdread-0.9.3 >=media-video/lsdvd-0.10 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-missing_stdint_headers.patch
+} \ No newline at end of file