summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-11 08:37:13 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-11 08:37:13 +0000
commit0a3466adef7803c96675080aad1812ed02d839dd (patch)
tree50f688bd332e36a4a035a864e4cc7a4c200c8e4b /dev-ruby/actionpack
parentVersion bumps for security bug 430718. (diff)
downloadgentoo-2-0a3466adef7803c96675080aad1812ed02d839dd.tar.gz
gentoo-2-0a3466adef7803c96675080aad1812ed02d839dd.tar.bz2
gentoo-2-0a3466adef7803c96675080aad1812ed02d839dd.zip
Version bumps for security bug 430718.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog9
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.17.ebuild63
-rw-r--r--dev-ruby/actionpack/actionpack-3.1.8.ebuild70
3 files changed, 141 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 3f5ba24337f1..dd7d12fa5bf6 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.215 2012/08/10 06:43:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.216 2012/08/11 08:37:13 graaff Exp $
+
+*actionpack-3.1.8 (11 Aug 2012)
+*actionpack-3.0.17 (11 Aug 2012)
+
+ 11 Aug 2012; Hans de Graaff <graaff@gentoo.org> +actionpack-3.0.17.ebuild,
+ +actionpack-3.1.8.ebuild:
+ Version bumps for security bug 430718.
*actionpack-3.2.8 (10 Aug 2012)
diff --git a/dev-ruby/actionpack/actionpack-3.0.17.ebuild b/dev-ruby/actionpack/actionpack-3.0.17.ebuild
new file mode 100644
index 000000000000..8f22d37d4001
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.0.17.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.17.ebuild,v 1.1 2012/08/11 08:37:13 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2:0
+ >=dev-ruby/erubis-2.6.6
+ >=dev-ruby/i18n-0.5.0:0.5
+ >=dev-ruby/rack-1.2.5:1.2
+ >=dev-ruby/rack-mount-0.6.14:0.6
+ >=dev-ruby/rack-test-0.5.7:0.5
+ >=dev-ruby/tzinfo-0.3.23"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ >=dev-ruby/mocha-0.10.5
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(system_timer\|horo\|faker\|rbench\|ruby-debug\|pg\|mysql2\)/d' ../Gemfile || die
+
+ # Loosen erubis dependency since this is not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' actionpack.gemspec || die
+
+ # Loosen mocha version restriction
+ sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
+
+ # Ignore failure introduced by security measures in 3.0.17.
+ sed -i -e '/test_select_tag_escapes_prompt/,/end/ s:^:#:' test/template/form_tag_helper_test.rb || die
+}
diff --git a/dev-ruby/actionpack/actionpack-3.1.8.ebuild b/dev-ruby/actionpack/actionpack-3.1.8.ebuild
new file mode 100644
index 000000000000..5e257507ce47
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.1.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.1.8.ebuild,v 1.1 2012/08/11 08:37:13 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-cache-1.2
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/i18n-0.6:0.6
+ >=dev-ruby/rack-1.3.6:1.3
+ >=dev-ruby/rack-mount-0.8.2:0.8
+ >=dev-ruby/rack-test-0.6.1:0.6
+ >=dev-ruby/sprockets-2.0.4:2.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ dev-ruby/bundler
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/tzinfo-0.3.29
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\)/d' ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+ sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
+
+ # Loosen mocha version restriction
+ sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+}