summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-26 18:02:47 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-26 18:02:47 +0000
commit2309b4d5b55f8dc922f72b5fc51133113ce31f2d (patch)
treed9e57b4c1d0d14832e19a5d8c63aa740b6f5be0c /dev-ruby/actionpack
parentVersion bump for Rails 3.0.7. (diff)
downloadgentoo-2-2309b4d5b55f8dc922f72b5fc51133113ce31f2d.tar.gz
gentoo-2-2309b4d5b55f8dc922f72b5fc51133113ce31f2d.tar.bz2
gentoo-2-2309b4d5b55f8dc922f72b5fc51133113ce31f2d.zip
Version bump for Rails 3.0.7.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.7.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index ac47369acc45..3309704b73b2 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.173 2011/03/14 19:42:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.174 2011/04/26 18:02:47 graaff Exp $
+
+*actionpack-3.0.7 (26 Apr 2011)
+
+ 26 Apr 2011; Hans de Graaff <graaff@gentoo.org> +actionpack-3.0.7.ebuild:
+ Version bump for Rails 3.0.7.
14 Mar 2011; Hans de Graaff <graaff@gentoo.org> actionpack-2.3.11.ebuild:
The tests run fine with test-unit now.
diff --git a/dev-ruby/actionpack/actionpack-3.0.7.ebuild b/dev-ruby/actionpack/actionpack-3.0.7.ebuild
new file mode 100644
index 000000000000..7d93d8135bc8
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.0.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.7.ebuild,v 1.1 2011/04/26 18:02:47 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2:0
+ >=dev-ruby/erubis-2.6.6
+ >=dev-ruby/i18n-0.5.0:0.5
+ >=dev-ruby/rack-1.2.1:1.2
+ >=dev-ruby/rack-mount-0.6.14
+ >=dev-ruby/rack-test-0.5.7
+ >=dev-ruby/tzinfo-0.3.23"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Loosen erubis and rack-mount dependencies since these are not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' -e 's/~> 0.6.14/>= 0.6.14/' actionpack.gemspec || die
+}