summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-07 12:35:01 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-07 12:35:01 +0000
commitbe2ddbc225c406116f8768024105284e58ec7df5 (patch)
tree74f62152d2245294da58c8fcf2f9050764956cf4 /dev-ruby/actionpack
parentVersion bump for Rails 4. Dropped keywords in bug 487206. (diff)
downloadgentoo-2-be2ddbc225c406116f8768024105284e58ec7df5.tar.gz
gentoo-2-be2ddbc225c406116f8768024105284e58ec7df5.tar.bz2
gentoo-2-be2ddbc225c406116f8768024105284e58ec7df5.zip
Version bump for Rails 4. Dropped keywords in bug 487206.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-4.0.0.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 1830dd31298d..0197f71ba9b2 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.256 2013/08/17 10:31:42 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.257 2013/10/07 12:35:01 graaff Exp $
+
+*actionpack-4.0.0 (07 Oct 2013)
+
+ 07 Oct 2013; Hans de Graaff <graaff@gentoo.org> +actionpack-4.0.0.ebuild:
+ Version bump for Rails 4. Dropped keywords in bug 487206.
*actionpack-3.2.14 (17 Aug 2013)
diff --git a/dev-ruby/actionpack/actionpack-4.0.0.ebuild b/dev-ruby/actionpack/actionpack-4.0.0.ebuild
new file mode 100644
index 000000000000..dd23becee4b0
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-4.0.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.0.0.ebuild,v 1.1 2013/10/07 12:35:01 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+ >=dev-ruby/rack-1.5.2:1.5
+ >=dev-ruby/rack-test-0.6.2:0.6
+ >=dev-ruby/sprockets-2.2.1:2.2
+ >=dev-ruby/erubis-2.7.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.13
+ dev-ruby/bundler
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ dev-ruby/sprockets-rails:2.0
+ >=dev-ruby/tzinfo-0.3.29
+ >=dev-ruby/uglifier-1.0.3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\)/d" ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
+
+ # Add back json in the Gemfile because we dropped some dependencies
+ # earlier that implicitly required it.
+ sed -i -e '$agem "json"' ../Gemfile || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+
+ # Avoid fragile test that gets more output than it expects.
+ sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
+}