summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-04-26 15:09:30 +0000
committerHans de Graaff <graaff@gentoo.org>2014-04-26 15:09:30 +0000
commit22d8435d921a9c94da957cdfc4779efb183e6cce (patch)
tree3ad2ec1f73a0432e43a6a736f50be80a98e2773b /dev-ruby/actionview
parentVersion bump for Rails 4.1. Drop x86, bug 508780. (diff)
downloadgentoo-2-22d8435d921a9c94da957cdfc4779efb183e6cce.tar.gz
gentoo-2-22d8435d921a9c94da957cdfc4779efb183e6cce.tar.bz2
gentoo-2-22d8435d921a9c94da957cdfc4779efb183e6cce.zip
Version bump for Rails 4.1. Drop x86, bug 508780.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionview')
-rw-r--r--dev-ruby/actionview/ChangeLog10
-rw-r--r--dev-ruby/actionview/actionview-4.1.0.ebuild46
-rw-r--r--dev-ruby/actionview/metadata.xml5
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/actionview/ChangeLog b/dev-ruby/actionview/ChangeLog
new file mode 100644
index 000000000000..9e1e847ec368
--- /dev/null
+++ b/dev-ruby/actionview/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/actionview
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.1 2014/04/26 15:09:30 graaff Exp $
+
+*actionview-4.1.0 (26 Apr 2014)
+
+ 26 Apr 2014; Hans de Graaff <graaff@gentoo.org> +actionview-4.1.0.ebuild,
+ +metadata.xml:
+ Version bump for Rails 4.1. Drop x86, bug 508780.
+
diff --git a/dev-ruby/actionview/actionview-4.1.0.ebuild b/dev-ruby/actionview/actionview-4.1.0.ebuild
new file mode 100644
index 000000000000..398bdc76ee95
--- /dev/null
+++ b/dev-ruby/actionview/actionview-4.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/actionview-4.1.0.ebuild,v 1.1 2014/04/26 15:09:30 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1 =dev-ruby/builder-3*
+ >=dev-ruby/erubis-2.7.0
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\)/ s:^:#:" ../Gemfile || die
+
+}
diff --git a/dev-ruby/actionview/metadata.xml b/dev-ruby/actionview/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/actionview/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>