summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-30 08:36:28 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-30 08:36:28 +0000
commit777fc8780c5c98d357f8d074fe1752a59114749e (patch)
tree868a1e3330b787799bcda3a1ceea1f0ea61e0bc4 /dev-ruby/activeldap
parentUse XEphem license wrt #436630 by Ulrich Müller <ulm@gentoo.org> (diff)
downloadgentoo-2-777fc8780c5c98d357f8d074fe1752a59114749e.tar.gz
gentoo-2-777fc8780c5c98d357f8d074fe1752a59114749e.tar.bz2
gentoo-2-777fc8780c5c98d357f8d074fe1752a59114749e.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activeldap')
-rw-r--r--dev-ruby/activeldap/ChangeLog7
-rw-r--r--dev-ruby/activeldap/activeldap-3.2.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/activeldap/ChangeLog b/dev-ruby/activeldap/ChangeLog
index aa72dbac9ea4..4ee13212c986 100644
--- a/dev-ruby/activeldap/ChangeLog
+++ b/dev-ruby/activeldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeldap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/ChangeLog,v 1.3 2012/08/16 15:21:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/ChangeLog,v 1.4 2012/09/30 08:36:28 graaff Exp $
+
+*activeldap-3.2.2 (30 Sep 2012)
+
+ 30 Sep 2012; Hans de Graaff <graaff@gentoo.org> +activeldap-3.2.2.ebuild:
+ Version bump.
16 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org>
activeldap-1.2.2-r1.ebuild:
diff --git a/dev-ruby/activeldap/activeldap-3.2.2.ebuild b/dev-ruby/activeldap/activeldap-3.2.2.ebuild
new file mode 100644
index 000000000000..4a8aa25aa1ea
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-3.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/activeldap-3.2.2.ebuild,v 1.1 2012/09/30 08:36:28 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile TODO"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="Ruby/ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_bdepend "dev-ruby/hoe"
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-3.2.8:3.2
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( >=dev-ruby/ruby-ldap-0.8.2 dev-ruby/ruby-net-ldap )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}